Commit e984749f authored by Christian Persch's avatar Christian Persch

Don't force VTE_SEAL_ENABLE on vte/gtk2

Only enforce it on vte 2.90 (gtk3).
parent 0574bcfb
......@@ -50,6 +50,7 @@ case "$with_gtk" in
VTE_API_MINOR_VERSION=0
VTE_PC_VERSION=
VTE_LIBRARY_SUFFIX=
VTE_SEAL_CFLAGS=
GTK_API_VERSION=2.0
GTK_REQUIRED=2.20.0
;;
......@@ -58,6 +59,7 @@ case "$with_gtk" in
VTE_API_MINOR_VERSION=90
VTE_PC_VERSION=-$VTE_API_VERSION
VTE_LIBRARY_SUFFIX=$VTE_API_VERSION
VTE_SEAL_CFLAGS="-DVTE_SEAL_ENABLE"
GTK_API_VERSION=3.0
GTK_REQUIRED=2.90.0
;;
......@@ -68,6 +70,7 @@ AC_SUBST([VTE_API_VERSION_U],[AS_TR_SH([$VTE_API_VERSION])])
AC_SUBST([VTE_API_MAJOR_VERSION])
AC_SUBST([VTE_API_MINOR_VERSION])
AC_SUBST([VTE_PC_VERSION])
AC_SUBST([VTE_SEAL_CFLAGS])
AC_SUBST([GTK_API_VERSION])
AC_SUBST([VTE_LIBRARY_SUFFIX_U],[AS_TR_SH([$VTE_LIBRARY_SUFFIX])])
......
......@@ -10,4 +10,4 @@ Description: Vte terminal widget.
Version: @VERSION@
Requires: @VTE_PKGS@
Libs: ${pc_top_builddir}/${pcfiledir}/src/libvte@VTE_LIBRARY_SUFFIX_U@.la
Cflags: -I${pc_top_builddir}/${pcfiledir}/src
Cflags: -I${pc_top_builddir}/${pcfiledir}/src @VTE_SEAL_CFLAGS@
......@@ -10,4 +10,4 @@ Description: Vte terminal widget.
Version: @VERSION@
Requires: @VTE_PKGS@
Libs: -L${libdir} -lvte@VTE_LIBRARY_SUFFIX_U@
Cflags: -I${includedir}/vte-@VTE_API_VERSION@ -DVTE_SEAL_ENABLE
Cflags: -I${includedir}/vte-@VTE_API_VERSION@ @VTE_SEAL_CFLAGS@
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment