Commit 23090c9c authored by Guido Günther's avatar Guido Günther

Introduce git-buildpackage-rpm

Currently only including "gbp import-srpm"
parent ed228a25
......@@ -18,10 +18,10 @@ docs/manpage.links
docs/manpage.refs
docs/version.ent
debian/git-buildpackage.*.debhelper
debian/git-buildpackage.debhelper.*
debian/git-buildpackage*.debhelper*
debian/python-module-stampdir/
debian/files
debian/git-buildpackage.substvars
debian/git-buildpackage*.substvars
debian/git-buildpackage/
debian/git-buildpackage-rpm/
debian/tmp/
......@@ -14,10 +14,13 @@ Build-Depends:
python-coverage,
python-dateutil,
python-epydoc,
python-mock,
python-nose,
python-nosexcover,
python-pkg-resources,
python-rpm,
python-setuptools,
rpm,
sgml2x,
# For the testsuite
bzip2,
......@@ -54,3 +57,17 @@ Description: Suite to help with Debian packages in Git repositories
* gbp {pull,clone}: clone and pull from remote repos
* gbp pq: manage debian/patches easily
* gbp create-remote-repo: create remote repositories
Package: git-buildpackage-rpm
Architecture: all
Depends: ${python:Depends},
${misc:Depends},
git-buildpackage (= ${binary:Version}),
python-rpm,
rpm,
Recommends: pristine-tar (>= 0.5)
Suggests: python-notify, unzip
Description: Suite to help with RPM packages in Git repositories
This package contains the following tools:
* gbp import-srpm: import existing RPM source packages into a git
repository
usr/lib/python2.?/dist-packages/gbp/rpm/
usr/lib/python2.7/dist-packages/gbp/scripts/import_srpm.py
usr/bin/
usr/lib/python2.?/dist-packages/gbp-*
usr/lib/python2.?/dist-packages/gbp/command_wrappers.py
usr/lib/python2.?/dist-packages/gbp/config.py
usr/lib/python2.?/dist-packages/gbp/dch.py
usr/lib/python2.?/dist-packages/gbp/deb/
usr/lib/python2.?/dist-packages/gbp/errors.py
usr/lib/python2.?/dist-packages/gbp/git/
usr/lib/python2.?/dist-packages/gbp/__init__.py
usr/lib/python2.?/dist-packages/gbp/log.py
usr/lib/python2.?/dist-packages/gbp/notifications.py
usr/lib/python2.?/dist-packages/gbp/patch_series.py
usr/lib/python2.?/dist-packages/gbp/pkg/
usr/lib/python2.?/dist-packages/gbp/scripts/buildpackage.py
usr/lib/python2.?/dist-packages/gbp/scripts/clone.py
usr/lib/python2.?/dist-packages/gbp/scripts/common/
usr/lib/python2.?/dist-packages/gbp/scripts/config.py
usr/lib/python2.?/dist-packages/gbp/scripts/create_remote_repo.py
usr/lib/python2.?/dist-packages/gbp/scripts/dch.py
usr/lib/python2.?/dist-packages/gbp/scripts/import_dsc.py
usr/lib/python2.?/dist-packages/gbp/scripts/import_dscs.py
usr/lib/python2.?/dist-packages/gbp/scripts/import_orig.py
usr/lib/python2.?/dist-packages/gbp/scripts/__init__.py
usr/lib/python2.?/dist-packages/gbp/scripts/pq.py
usr/lib/python2.?/dist-packages/gbp/scripts/pull.py
usr/lib/python2.?/dist-packages/gbp/scripts/supercommand.py
usr/lib/python2.?/dist-packages/gbp/tmpfile.py
usr/lib/python2.?/dist-packages/gbp/tristate.py
usr/lib/python2.?/dist-packages/gbp/version.py
etc/git-buildpackage/gbp.conf
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment