Commit ab4de200 authored by Guido Günther's avatar Guido Günther

Add gbp-import-dsc hook for pk4

Can be enables via

    mkdir -p ~/.config/pk4/hooks-enabled/unpack/
    ln -s /usr/share/pk4/hooks-available/unpack/gbp \
          ~/.config/pk4/hooks-enabled/unpack/
parent ccfa5631
#!/bin/sh
set -e
if [ ! -d "$2" ]; then
git init "$2"
# Add local gbp.conf to override any branch settings in 'debian/gbp.conf'
# (since this checkout wasn't created by "gbp clone"). We want to be sure the
# branches exist so we can build the package right away.
cat <<EOF > "$2"/.git/gbp.conf
[DEFAULT]
upstream-branch = upstream
debian-branch = pk4
EOF
fi
cd "$2"
gbp import-dsc "$1"
......@@ -10,6 +10,7 @@ EXAMPLE_SCRIPTS=\
DEB_COMPRESS_EXCLUDE=$(EXAMPLE_SCRIPTS)
ZSH_COMPDIR = /usr/share/zsh/vendor-completions/
PK4_DIR = /usr/share/pk4/hooks-available/unpack/
PYCHECKER_ARGS=-boptparse --no-override --no-shadowbuiltin
......@@ -33,6 +34,9 @@ override_dh_auto_install:
mkdir -p debian/git-buildpackage/$(ZSH_COMPDIR)
install -m644 debian/git-buildpackage.zsh-completion \
debian/git-buildpackage/$(ZSH_COMPDIR)/_gbp
mkdir -p debian/git-buildpackage/$(PK4_DIR)
install -m755 debian/pk4 \
debian/git-buildpackage/$(PK4_DIR)/gbp
chmod a+x debian/tmp/usr/lib/python3.?/dist-packages/gbp/scripts/supercommand.py
override_dh_auto_clean:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment