Commit b3930de7 authored by Martin Pitt's avatar Martin Pitt

pg_createcluster: Show the locale selected with --locale instead of the current one

LP: #1467061
parent f39856a2
postgresql-common (170) UNRELEASED; urgency=medium
[ Christoph Berg ]
* pg_createcluster, pg_dropcluster: When an auto-started cluster is created/
dropped by root, notify systemd to update the dependencies of
postgresql.service.wants.
......@@ -14,6 +15,10 @@ postgresql-common (170) UNRELEASED; urgency=medium
not support that anymore as of May 2015.
* t/170_extensions.t: Catch warning with chkpass >= 9.5.
[ Martin Pitt ]
* pg_createcluster: Show the locale selected with --locale instead of the
current one. (LP: #1467061)
-- Christoph Berg <christoph.berg@credativ.de> Fri, 05 Jun 2015 16:23:57 +0200
postgresql-common (169) unstable; urgency=medium
......
......@@ -362,7 +362,7 @@ if (-f "$datadir/PG_VERSION") {
error "$datadir already contains a version $existingver cluster";
}
} else {
my $loc = setlocale (LC_CTYPE);
my $loc = $locale || setlocale (LC_CTYPE);
print "Creating new cluster $version/$cluster ...\n";
print " config $confdir\n data $datadir\n locale $loc\n";
init_db $version, $datadir, $owneruid, $ownergid, \@initdb_opts_from_cli;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment