Commit e15279f5 authored by Christoph Berg's avatar Christoph Berg

dh_make_pgxs: Set debhelper compat level to 9, highest version supported by jessie and trusty.

parent 882ea804
......@@ -7,6 +7,8 @@ postgresql-common (201) UNRELEASED; urgency=medium
* gitlab-ci.yml: Ignore skipped tests, and packages without tests.
* gitlab-ci.yml: Install pristine-tar.
* dh_make_pgxs: Add debian/gitlab-ci.yml.
* dh_make_pgxs: Set debhelper compat level to 9, highest version supported
by jessie and trusty.
-- Christoph Berg <myon@debian.org> Sun, 03 Mar 2019 18:02:47 +0100
......
#!/bin/bash
# (C) 2015-2017 Christoph Berg <myon@debian.org>
# (C) 2015-2019 Christoph Berg <myon@debian.org>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
......@@ -37,7 +37,8 @@ shift $((OPTIND - 1)) # shift away args
SOURCE="${NAME//_/-}" # Debian name
EXTNAME="$(echo $SOURCE | sed -e 's/^\(postgresql\|pgsql\|pg\)-//')" # binary package name suffix
COMPAT="$(apt-cache show debhelper | sed -n 's/Version: \([0-9]*\)\..*/\1/p' | head -n1)"
#COMPAT="$(apt-cache show debhelper | sed -n 's/Version: \([0-9]*\)\..*/\1/p' | head -n1)"
COMPAT="9" # highest version supported in Debian oldoldstable and Ubuntu oldoldLTS
STANDARDS_VERSION="$(apt-cache show debian-policy | sed -n 's/Version: \(.*\)\..*/\1/p' | head -n1)"
USERNAME=${LOGNAME:-${USER:-root}}
MAINTAINER_NAME=$(getent passwd $USERNAME | cut -d : -f 5 | sed -e 's/,.*//')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment