Build with `libjaxb-api-java`

parent e93e9e15
Pipeline #28774 failed with stage
in 1 minute and 39 seconds
......@@ -28,6 +28,7 @@ Build-Depends:
libintellij-annotations-java,
libjacoco-java (>= 0.7.8-1~),
libjavawriter-java,
libjaxb-api-java,
libjdom1-java,
libjimfs-java (>= 1.1-3~),
libjna-java,
......@@ -110,6 +111,7 @@ Depends: android-platform-tools-base,
libguava-java,
libjacoco-java,
libjavawriter-java,
libjaxb-api-java,
libjdom1-java,
libjna-java,
libjna-platform-java,
......@@ -159,6 +161,7 @@ Depends: libandroid-layoutlib-api-java (>= ${binary:Version}),
libgoogle-gson-java,
libhttpclient-java,
libhttpmime-java,
libjaxb-api-java,
libjimfs-java,
${misc:Depends}
Description: Library to parse and download the Android SDK
......@@ -206,6 +209,7 @@ Package: libandroid-tools-repository-java
Architecture: all
Depends: libandroid-tools-common-java (>= ${binary:Version}),
libcommons-compress-java,
libjaxb-api-java,
${misc:Depends}
Description: Library for downloading and managing package repositories
This library provides the API to parse the XML format manifest of Android SDK's
......
Author: Markus Koschany <apo@debian.org>
Last-Update: 2016-07-19
Forwarded: not-needed
Description: Patch upstream's build system for Debian.
This patch does the following:
......@@ -199,7 +198,15 @@ Description: Patch upstream's build system for Debian.
compile 'org.ow2.asm:asm:5.0.4'
compile 'org.ow2.asm:asm-commons:5.0.4'
compile "net.sf.proguard:proguard-gradle:${project.ext.proguardVersion}"
@@ -50,6 +49,7 @@
@@ -43,6 +42,7 @@
compile "org.jacoco:org.jacoco.report:0.7.5.201505241946" // update JacocoPlugin.
compile "net.sf.jopt-simple:jopt-simple:4.9"
compile "com.google.protobuf:protobuf-java:2.5.0"
+ compile 'javax.xml.bind:jaxb-api:debian'
testCompile project(':base:instant-run:instant-run-annotations')
testCompile project(':base:instant-run:instant-run-runtime')
@@ -50,6 +50,7 @@
// Add gradleApi to classpath for compilation, but use provided configuration so that groovy is
// not exposed as a runtime dependency.
provided gradleApi()
......@@ -207,7 +214,7 @@ Description: Patch upstream's build system for Debian.
// Exclude plugins/core-* to avoiding adding Gradle's ecj implementation to the classpath
testCompile fileTree(
@@ -82,8 +82,6 @@
@@ -82,8 +83,6 @@
project.ext.pomName = 'Core Library for Android Gradle Plug-in'
project.ext.pomDesc = 'Core library to build Android Gradle plugin.'
......@@ -216,7 +223,7 @@ Description: Patch upstream's build system for Debian.
test {
environment("CUSTOM_REPO", rootProject.file("../out/repo"))
@@ -102,7 +100,6 @@
@@ -102,7 +101,6 @@
docTitle "Gradle Plugin for Android"
header ""
footer "Copyright (C) 2012 The Android Open Source Project"
......@@ -224,7 +231,7 @@ Description: Patch upstream's build system for Debian.
groovyClasspath = configurations.provided
}
@@ -117,12 +114,6 @@
@@ -117,12 +115,6 @@
classpath += configurations.provided
}
......@@ -623,7 +630,15 @@ Description: Patch upstream's build system for Debian.
evaluationDependsOn(':base:dvlib')
@@ -118,7 +125,3 @@
@@ -19,6 +26,7 @@
compile 'org.apache.commons:commons-compress:1.8.1'
compile 'org.apache.httpcomponents:httpclient:4.1.1'
compile 'org.apache.httpcomponents:httpmime:4.1'
+ compile 'javax.xml.bind:jaxb-api:debian'
testCompile project(':base:dvlib').sourceSets.test.output
testCompile 'junit:junit:4.12'
@@ -118,7 +126,3 @@
project.ext.pomName = 'Android Tools sdklib'
project.ext.pomDesc = 'A library to parse and download the Android SDK.'
......@@ -690,7 +705,15 @@ Description: Patch upstream's build system for Debian.
group = 'com.android.tools'
archivesBaseName = 'repository'
@@ -30,10 +29,6 @@
@@ -10,6 +9,7 @@
compile project(':base:common')
compile 'org.apache.commons:commons-compress:1.8.1'
compile 'com.google.jimfs:jimfs:1.1'
+ compile 'javax.xml.bind:jaxb-api:debian'
testCompile 'junit:junit:4.12'
}
@@ -30,10 +30,6 @@
project.ext.pomName = 'Android Tools repository'
project.ext.pomDesc = 'A library for downloading and managing package repositories'
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment