Commit 2e071481 authored by Julian Andres Klode's avatar Julian Andres Klode

Switch to python3-sphinx

parent 75fdafb8
......@@ -16,7 +16,7 @@ Build-Depends: apt (>= 1.0.9.4),
python3-all-dbg (>= 3.3),
python3-distutils | python3 (<< 3.6) | python3.6 (<< 3.6.4~rc1-2),
python-distutils-extra (>= 2.0),
python-sphinx (>= 0.5),
python3-sphinx (>= 0.5),
gnupg,
dirmngr | gnupg (<< 2),
pep8,
......
......@@ -29,7 +29,7 @@ override_dh_sphinxdoc:
override_dh_installdocs:
set -e; if [ -z $(filter -a,$(DH_INTERNAL_OPTIONS)) ]; then \
python setup.py build_sphinx; \
python3 setup.py build_sphinx; \
dh_installdirs -ppython-apt-doc usr/share/doc/python-apt; \
fi
dh_installdirs -ppython-apt-dev usr/share/doc/python-apt
......
......@@ -74,9 +74,10 @@ except KeyError:
stdout=PIPE)
p2 = Popen(["sed", "-n", 's/^Version: //p'], stdin=p1.stdout, stdout=PIPE)
release = p2.communicate()[0]
if sys.version_info.major >= 3:
release = release.decode("utf-8")
if sys.version_info.major >= 3:
release = release.decode("utf-8")
# Handle the alpha release scheme
release_raw = "0"
for c in release.split("~")[0].split(".")[2]:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment