Commit 55983b83 authored by Julian Andres Klode's avatar Julian Andres Klode

Release 1.1.0~alpha1

This is practically the same as in the unstable branch, plus built
against the new APT ABI.
parent 512f8f3b
python-apt (1.1.0~alpha1) experimental; urgency=medium
[ Michael Vogt ]
* apt/debfile.py: use apt_pkg.open_maybe_clear_signed_file() when opening a .dsc file
[ Julian Andres Klode ]
* Drop apt_pkg.IndexRecords, it has been dropped in experimental
* Support APT_PKG_MAJOR >= 5
* test_paths: Drop the indexrecord test
* Fix pep8 1.6.2 issues
* setup.py: Pass -std=c++11 and -Wno-write-strings to the compiler
* Convert from SPtr and SPtrArray to unique_ptr and array
* Replace pkgDistUpgrade and friend with APT::Upgrade::Upgrade
* AcquireItem: Deprecate mode and introduce active_subprocess
[ John R. Lenton ]
* Discard stderr when calling system-image-cli (LP: #267935)
-- Julian Andres Klode <jak@debian.org> Tue, 18 Aug 2015 14:44:51 +0200
python-apt (1.0.0~beta3.1) unstable; urgency=medium
[ Michael Vogt ]
......
......@@ -11,7 +11,7 @@ Build-Depends: apt (>= 1.0.9.4),
debhelper (>= 9),
dh-python,
fakeroot,
libapt-pkg-dev (>= 1.0.4~),
libapt-pkg-dev (>= 1.1~exp9),
python-all-dev (>= 2.7),
python-all-dbg,
python3-all-dev (>= 3.3),
......
What's New In python-apt 1.1
==============================
This release is built against APT 1.1
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment