Commit d6354770 authored by Georges Khaznadar's avatar Georges Khaznadar

included changes from Ajith Kumar and Boyuan Yang

parent 5be285a9
expeyes (4.4.3+dfsg-2) unstable; urgency=medium
* removed any dependency on python2
* applied Boyuan Yang's patch. Closes: #904090
* applied a patch from Ajith Kumar, which add examples for eyes17,
in Python language.
-- Georges Khaznadar <georgesk@debian.org> Fri, 20 Jul 2018 17:39:12 +0200
expeyes (4.4.3+dfsg-1) unstable; urgency=medium
* added Frans Spiesschaert's nl.po file. Closes: #898869
......
......@@ -3,7 +3,7 @@ Section: science
Priority: optional
Maintainer: Georges Khaznadar <georgesk@debian.org>
Build-Depends: debhelper (>= 10), quilt,
python3-all, python-all, dh-python,
python3-all, dh-python,
gcc-avr, binutils-avr, avr-libc (>=1:1.8.0+Atmel3.5.0),
pkg-config, libgtk2.0-dev, x11proto-randr-dev (>= 1.5.0),
pyqt5-dev-tools, qttools5-dev-tools
......@@ -14,12 +14,12 @@ Vcs-Git: https://salsa.debian.org/georgesk/expeyes.git
Package: expeyes
Architecture: all
Depends: python, python3, ${misc:Depends},
python-expeyes (= ${source:Version}),
python3-pil.imagetk, python-pil.imagetk,
tix, python3-tk, python-tk, udev
Recommends: python-numpy, python-scipy, python3-numpy, python3-scipy,
expeyes-web, qtiplot, python-pygrace(>=0.5),python3-pygrace(>=0.5),
Depends: python3, ${misc:Depends}, ${python3:Depends}
python3-expeyes (= ${source:Version}),
python3-pil.imagetk,
tix, python3-tk, udev
Recommends: python3-numpy, python3-scipy,
expeyes-web, qtiplot, python3-pygrace(>=0.5),
expeyes-doc-en|expeyes-doc
Description: hardware & software framework for developing science experiments
This package provides high level interfaces for making science experiments
......@@ -37,11 +37,11 @@ Description: hardware & software framework for developing science experiments
Package: eyes17
Architecture: all
Depends: python, python3, ${misc:Depends},
python-expeyes (= ${source:Version}),
Depends: python3, ${misc:Depends}, ${python3:Depends}
python3-expeyes (= ${source:Version}),
python3-pyqtgraph, python3-pyqt5, python3-pyqt5.qtwebkit,
python-configparser
Recommends: python-numpy, python-scipy, python3-numpy, python3-scipy,
Recommends: python3-numpy, python3-scipy,
python3-pyqt5.qtwebengine
Description: hardware & software framework for developing science experiments
This package provides high level interfaces for making science experiments
......@@ -119,15 +119,13 @@ Description: hardware & software framework for developing science experiments
design is also open.
Package: python-expeyes
Package: python3-expeyes
Section: python
Architecture: all
Depends: python, python3, ${misc:Depends},
python3-scipy, python3-serial (>= 2.6),
python-scipy, python-serial (>= 2.6)
Provides: python3-expeyes
Depends: python3, ${misc:Depends}, ${python3:Depends},
python3-scipy, python3-serial (>= 2.6)
Recommends: udev
Description: Python library for expeyes
Description: Python3 library for expeyes
This package provides low level interfaces for making science experiments
with an ExpEYES box. The library allows one to develop new programs easily
.
......@@ -144,8 +142,8 @@ Description: Python library for expeyes
Package: expeyes-web
Section: web
Architecture: all
Depends: python, python3, ${misc:Depends},
python-expeyes, libjs-jquery, libjs-bootstrap
Depends: python3, ${misc:Depends}, ${python3:Depends},
python3-expeyes, libjs-jquery, libjs-bootstrap
Description: Web interface for expEYES-Junior
This package allows you to access remotely to a server which drives an
expEYES-Jr box. This extends the power of expEYES.
......@@ -153,7 +151,7 @@ Description: Web interface for expEYES-Junior
Package: microhope
Architecture: any
Depends: ${python:Depends}, ${misc:Depends}, ${shlibs:Depends},
expeyes, python-tk, avr-libc, avrdude, gnome-icon-theme,
expeyes, python3-tk, avr-libc, avrdude, gnome-icon-theme,
python-wxgtk3.0
Recommends: gnome-human-icon-theme
Description: hardware & software framework to learn microcontrollers
......
......@@ -5,6 +5,7 @@ usr/share/expeyes/eyes17/lang/*.ts usr/share/eyes17/lang
usr/share/expeyes/eyes17/*.py usr/share/eyes17
usr/share/eyes17/doc usr/share/eyes17
usr/share/eyes17/rst usr/share/eyes17
eyes17/examples usr/share/eyes17
desktop/expeyes-17.desktop usr/share/applications
desktop/eyes17-doc.desktop usr/share/applications
pixmaps/eyes17-logo.png usr/share/icons
......
This diff is collapsed.
0001-Use-Qt5-lrelease-pylupdate5-instead-of-qt4-tools.patch
0010_examplesForEyes17.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment