...
 
Commits (2)
...@@ -2,8 +2,10 @@ gjs (1.55.92-1) UNRELEASED; urgency=medium ...@@ -2,8 +2,10 @@ gjs (1.55.92-1) UNRELEASED; urgency=medium
* New upstream release * New upstream release
* debian/watch: enable watching for any version * debian/watch: enable watching for any version
* Bump Standards-Version to 4.3.0
* debian/rules: Drop the "Provides=libgjs0-libmozjs-52-0"
-- Andrea Azzarone <andrea.azzarone@canonical.com> Thu, 07 Mar 2019 12:57:09 +0000 -- Andrea Azzarone <andrea.azzarone@canonical.com> Thu, 07 Mar 2019 14:57:28 +0000
gjs (1.54.3-1) unstable; urgency=medium gjs (1.54.3-1) unstable; urgency=medium
......
...@@ -36,14 +36,3 @@ endif ...@@ -36,14 +36,3 @@ endif
override_dh_makeshlibs: override_dh_makeshlibs:
dh_makeshlibs -Xusr/lib/gjs-1.0/ -V'libgjs0g (>= $(DEB_VERSION_EPOCH_UPSTREAM))' -- -c4 dh_makeshlibs -Xusr/lib/gjs-1.0/ -V'libgjs0g (>= $(DEB_VERSION_EPOCH_UPSTREAM))' -- -c4
# We don't actually use mozjs52 any more, but our ABI is compatible with
# the gjs that did.
#
# Yes, this really says libmozjs-52-0. Yes, this is intentional, even
# though we're now building against mozjs60. It's like this to avoid an
# unnecessary transition: programs built against gjs 1.52.x do not need
# to be rebuilt for 1.54.x.
override_dh_gencontrol:
echo gjs:Provides=libgjs0-libmozjs-52-0 >> debian/libgjs0g.substvars
dh_gencontrol