Commit 687ec608 authored by Rhonda D'Vine's avatar Rhonda D'Vine 🏳🌈

old BSAs

parent d39eb64f
[[!meta date="2013-02-25 20:10:44 UTC"]]
I uploaded new packages for nginx which fixed the following security
problems:
CVE-2012-4929 - nginx -- vulnerable to CRIME SSL attack
The TLS protocol 1.2 and earlier, as used in Mozilla Firefox, Google
Chrome, Qt, and other products, can encrypt compressed data without
properly obfuscating the length of the unencrypted data, which allows
man-in-the-middle attackers to obtain plaintext HTTP headers by observing
length differences during a series of guesses in which a string in an HTTP
request potentially matches an unknown string in an HTTP header, aka a
"CRIME" attack.
Nginx < 1.2.2 is only vulnerable when built with openssl < 1.0.0
This has been corrected in upstream 1.2.2 version.
For the squeeze-backports distribution the problems have been fixed in
version
1.2.1-2.2~bpo+60+2
For Squeeze (stable) this was fixed in version
0.7.67-3+squeeze3
Wheezy (testing) and Sid (unstable) are not vulnerable to this security
issue.
[[!meta date="2013-06-20 20:20:26 UTC"]]
Dominic Hargreaves uploaded new packages for request-tracker4 which
fixed the following security problems:
CVE-2012-4733
A user with the ModifyTicket right can bypass the DeleteTicket right
or any custom lifecycle transition rights and thus modify ticket data
without authorization.
CVE-2013-3368
The rt command line tool uses semi-predictable temporary files. A
malicious user can use this flaw to overwrite files with permissions
of the user running the rt command line tool.
CVE-2013-3369
A malicious user who is allowed to see administration pages can run
arbitrary mason components (without control of arguments), which may
have negative side-effects.
CVE-2013-3370
Request Tracker allows direct requests to private callback
components, which could be used to exploit a Request Tracker
extension or a local callback which uses the arguments passed to it
insecurely.
CVE-2013-3371
Request Tracker is vulnerable to cross-site scripting attacks via
attachment filenames.
CVE-2013-3372
Dominic Hargreaves discovered that Request Tracker is vulnerable to
an HTTP header injection limited to the value of the
Content-Disposition header.
CVE-2013-3373
Request Tracker is vulnerable to a MIME header injection in outgoing
email generated by Request Tracker.
Request Tracker stock templates are resolved by this update. But any
custom email templates should be updated to ensure that values
interpolated into mail headers do not contain newlines.
CVE-2013-3374
Request Tracker is vulnerable to limited session re-use when using
the file-based session store, Apache::Session::File. However Request
Tracker's default session configuration only uses
Apache::Session::File when configured for Oracle databases.
This version of Request Tracker includes a database content upgrade. If
you are using a dbconfig-managed database, you will be offered the
choice of applying this automatically. Otherwise see the explanation in
/usr/share/doc/request-tracker4/NEWS.Debian.gz for the manual steps to
perform.
Please note that if you run request-tracker4 under the Apache web
server, you must stop and start Apache manually. The "restart" mechanism
is not recommended, especially when using mod_perl or any form of
persistent perl process such as FastCGI or SpeedyCGI.
For the squeeze-backports distribution the problems have been fixed in
version 4.0.7-5+deb7u2~bpo60+1.
[[!meta date="2013-06-19 20:59:41 UTC"]]
One security issue has been found in HAProxy, a load-balancing reverse
proxy:
CVE-2013-2175
Denial of service in parsing HTTP headers.
For the backports for the oldstable distribution
(squeeze-backports-sloppy), the problem has been fixed in version
1.4.24-1~bpo60+1.
For the backports for the stable distribution (wheezy-backports), the
problem has been fixed in version 1.4.24-1~bpo70+1.
For the oldstable distribution (squeeze), the problem has been fixed in
version 1.4.8-1+squeeze1. See DSA 2711-1.
The stable distribution (wheezy) doesn't contain haproxy.
For the unstable distribution (sid), the problem has been fixed in
version 1.4.24-1. See DSA 2711-1.
We recommend that you upgrade your haproxy packages.
[[!meta date="2013-06-19 18:45:09 UTC"]]
Russ Allbery uploaded new packages for xml-security-c that fixed the
following security problems discovered by James Forshaw from Context
Information Security:
CVE-2013-2153
The implementation of XML digital signatures in the Santuario-C++
library is vulnerable to a spoofing issue allowing an attacker to
reuse existing signatures with arbitrary content.
CVE-2013-2154
A stack overflow, possibly leading to arbitrary code execution,
exists in the processing of malformed XPointer expressions in the
XML Signature Reference processing code.
CVE-2013-2155
A bug in the processing of the output length of an HMAC-based XML
Signature would cause a denial of service when processing specially
chosen input.
CVE-2013-2156
A heap overflow exists in the processing of the PrefixList attribute
optionally used in conjunction with Exclusive Canonicalization,
potentially allowing arbitary code execution.
For the squeeze-backports distribution, the problems have been fixed in
version 1.6.1-5+deb7u1~bpo60+1.
We recommend that you upgrade your xml-security-c packages, particularly
libxml-security-c16, if it was installed via backports.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment