Commit 4e6dd9c0 authored by Guido Günther's avatar Guido Günther

Use install_requirements

parent 3c0d1168
......@@ -7,7 +7,7 @@ services:
python:
- "2.7"
install: "pip install -r requirements.txt"
install: "pip install -r dev_requirements.txt"
script:
- flake8
- tests/helpers/run-in-docker
-r requirements.txt
coverage>=2.85
flake8>=3
mock
nose>=0.11.1
nosexcover>=1.0.7
......@@ -74,6 +74,10 @@ setup(name="gbp",
packages=find_packages(exclude=['tests', 'tests.*']),
data_files=[("share/git-buildpackage/", ["gbp.conf"]), ],
requires=["six", 'dateutil'],
install_requires=[
'python-dateutil',
'six>=1.9.0',
],
setup_requires=setup_requires(),
entry_points={
'console_scripts': ['gbp=gbp.scripts.supercommand:supercommand'],
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment