Commit 9cbb9df7 authored by Guido Günther's avatar Guido Günther

Use relative patch to install gbp.conf

to make pip install --user work
parent a3573a20
......@@ -29,4 +29,4 @@ usr/lib/python2.?/dist-packages/gbp/scripts/supercommand.py
usr/lib/python2.?/dist-packages/gbp/tmpfile.py
usr/lib/python2.?/dist-packages/gbp/tristate.py
usr/lib/python2.?/dist-packages/gbp/version.py
etc/git-buildpackage/gbp.conf
usr/share/git-buildpackage/gbp.conf etc/git-buildpackage/gbp.conf
......@@ -161,6 +161,8 @@ rm -rf %{buildroot}
WITHOUT_NOSETESTS=1 %{__python} ./setup.py install --root=%{buildroot} --prefix=/usr
mkdir -p %{buildroot}/usr/share/%{name}
mv %{buildroot}/usr/bin/gbp-builder-mock %{buildroot}/usr/share/%{name}/
mkdir -p %{buildroot}/%{_sysconfdir}/git-buildpackage/
mv %{buildroot}/usr/share/%{name}/gbp.conf %{buildroot}/%{_sysconfdir}/git-buildpackage/
%if %{with docs}
# Install man pages
......
......@@ -72,7 +72,7 @@ setup(name="gbp",
scripts=['bin/git-pbuilder',
'bin/gbp-builder-mock'],
packages=find_packages(exclude=['tests', 'tests.*']),
data_files=[("/etc/git-buildpackage/", ["gbp.conf"]), ],
data_files=[("share/git-buildpackage/", ["gbp.conf"]), ],
requires=["six"],
setup_requires=setup_requires(),
entry_points={
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment