Commit f50069a7 authored by Markus Lehtonen's avatar Markus Lehtonen Committed by Guido Günther

rpm packaging: update dependency on rpm-build

Most RPM-based distribution now support weak dependencies. Make
rpm-build a weak dependency (on other systems as openSUSE, too) as it's
not strictly needed by buildpackage-rpm: in Fedora people probably use
'mock' and in openSUSE they use 'osc' for building packages, for
example.
Signed-off-by: 's avatarMarkus Lehtonen <markus.lehtonen@linux.intel.com>
parent e51358f8
......@@ -106,10 +106,10 @@ Group: Development/Tools/Building
Requires: %{name}-common = %{version}-%{release}
Requires: rpm
Requires: %{rpm_python_pkg_name}
%if 0%{?suse_version} || 0%{?tizen_version:1}
Recommends: rpm-build
%else
%if 0%{?centos_ver} && 0%{?centos_ver} <= 7
Requires: rpm-build
%else
Recommends: rpm-build
%endif
%description rpm
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment