Commit a328b3df authored by Tristan Seligmann's avatar Tristan Seligmann

Remove deprecated CDBS dependency management.

parent 8eea4ee4
......@@ -7,6 +7,7 @@ electrum (1.9.5-1) UNRELEASED; urgency=low
* Add myself to Uploaders.
* Update mk18n.py patch and ship new translations file.
* Bump dependency on python-ecdsa for secp256k1.
* Remove deprecated CDBS dependency management.
-- Tristan Seligmann <mithrandi@debian.org> Wed, 27 Nov 2013 23:35:59 +0200
......
......@@ -24,7 +24,7 @@ Section: python
Architecture: all
Depends: ${misc:Depends},
${python:Depends},
${cdbs:Depends}
python-ecdsa (>= 0.9~), python-slowaes
Description: Easy to use bitcoin client - python module
This package provides a light weight bitcoin client which protects
you from loosing your bitcoin in a backup mistake or computer
......@@ -37,8 +37,8 @@ Description: Easy to use bitcoin client - python module
Package: electrum
Architecture: all
Depends: ${misc:Depends},
${cdbs:Depends},
python-electrum (= ${binary:Version})
python (>= 2.6),
python-electrum (= ${binary:Version}),
Description: Easy to use bitcoin client
This package provides a light weight bitcoin client which protects
you from loosing your bitcoin in a backup mistake or computer
......
Source: electrum
Priority: optional
Section: utils
Maintainer: Debian Bitcoin Packaging Team <pkg-bitcoin-devel@lists.alioth.debian.org>
Uploaders: Vasudev Kamath <kamathvasudev@gmail.com>
Build-Depends: @cdbs@
Standards-Version: 3.9.4
Homepage: http://electrum.org/
Vcs-Git: git://anonscm.debian.org/pkg-bitcoin/electrum.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-bitcoin/electrum.git
X-Python-Version: >= 2.6
Package: python-electrum
Section: python
Architecture: all
Depends: ${misc:Depends},
${python:Depends},
${cdbs:Depends}
Description: Easy to use bitcoin client - python module
This package provides a light weight bitcoin client which protects
you from loosing your bitcoin in a backup mistake or computer
failure. Also electrum does not require waiting time because it does
not download bitcoin block chain.
.
This package provides electrum Python module which can be used to
access bitcoin wallet from Python programs.
Package: electrum
Architecture: all
Depends: ${misc:Depends},
${cdbs:Depends},
python-electrum (= ${binary:Version})
Description: Easy to use bitcoin client
This package provides a light weight bitcoin client which protects
you from loosing your bitcoin in a backup mistake or computer
failure. Also electrum does not require waiting time because it does
not download bitcoin block chain.
.
Features of the electurm are listed. below
* Instant on: client does not download block chain, uses remote
server
* Forgiving: wallet can be recovered from secret seed.
* Safe: seed or private keys are not sent to the server,
information received from the server is verified using SPV.
* No downtimes: several public servers are available, so one can
switch instantly.
* Ubiquitous: same wallet can be used on different server, it will
auto syncrhonize.
* Open: private keys can be exported into other clients.
\ No newline at end of file
......@@ -18,21 +18,6 @@ package = electrum
python_module = python-$(package)
# dependency
electrum_depends = python-ecdsa, python-slowaes
# CDBS build depends
CDBS_BUILD_DEPENDS += , $(electrum_depends), pyqt4-dev-tools
# Suppress unneeded build-dependencies
CDBS_BUILD_DEPENDS_class_python-distutils_python =
# dependency for module
CDBS_DEPENDS_$(python_module) += $(electrum_depends), python-qt4
# dependency for program
CDBS_DEPENDS_$(package) += python (>= 2.6)
# Move aes and ecdsa from build directory to let package link against
# the python-ecdsa and python-slowaes
DEB_UPSTREAM_CRUFT_MOVE = ecdsa aes
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment