Commit e8b03632 authored by Julian Taylor's avatar Julian Taylor

bump pypy build dependency to 2.2, required for cffi patch to work.

parent a45afd4a
......@@ -2,6 +2,7 @@ pyzmq (14.0.1-2) unstable; urgency=low
* fix minitornado copyright information
thanks to Thorsten Alteholz for the report
* bump pypy build dependency to 2.2, required for cffi patch to work.
-- Julian Taylor <jtaylor.debian@googlemail.com> Sat, 11 Jan 2014 17:31:04 +0100
......
......@@ -9,7 +9,7 @@ Build-Depends: cython (>= 0.16),
dh-python (>= 1.20131021-1~),
dpkg-dev (>= 1.16.1~),
libzmq3-dev,
pypy (>= 2.0.0),
pypy (>= 2.2),
python-all-dbg (>= 2.6.6-3~),
python-all-dev (>= 2.6.6-3~),
python-nose,
......
......@@ -5,6 +5,8 @@ Description: check package root for cffi binaries
Also use fixed path in a place passed to cffi to get the same checksum
in build and install. After it is installed no build is needed so it doesn't
matter if its wrong.
This patch assumes pypy 2.2 api, won't work with 2.1 as so_suffices is no
list.
Bug: https://bitbucket.org/cffi/cffi/issue/109/enable-sane-packaging-for-cffi
--- a/zmq/backend/cffi/__init__.py
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment