Commit 8c3dca60 authored by Bernhard Link's avatar Bernhard Link

change version to 1:3.7.4-2

update Standards-Version
remove outdated Vcs- fields
set harding=+all, simplify buildflags
switch to debhelper 12
parent 674e5526
gv (1:3.7.4-2) unstable; urgency=medium
* bump Standards-Version
* remove outdated Vcs- fields
* set harding=+all, unconditionally use dpkg-buildflags
* switch to debhelper 12
-- Bernhard R. Link <brlink@debian.org> Sun, 27 Jan 2019 19:09:22 +0100
gv (1:3.7.4-1) unstable; urgency=low
* new upstream release
......@@ -381,7 +390,7 @@ gv (1:3.6.1-9) unstable; urgency=medium
gv (1:3.6.1-8) unstable; urgency=low
* Enabled signal handling, closes: #294863.
* Enabled signal handling, closes: #294863.
* This time really added DEB_BUILD_OPTIONS="debug", see 1:3.6.1-7.
-- Martin A. Godisch <godisch@debian.org> Sat, 12 Feb 2005 07:41:25 +0100
......@@ -502,8 +511,8 @@ gv (1:3.5.8-29) unstable; urgency=low
gv (1:3.5.8-28) unstable; urgency=low
* Prevent gv from rashly triggering TOC update if only numeric keypad
navigation was used (thanx to Sebastian Leske
<Sebastian.Leske@bigfoot.de> for tracking down this problem)
navigation was used (thanx to Sebastian Leske
<Sebastian.Leske@bigfoot.de> for tracking down this problem)
(closes: #166654)
* Quotes in man page fixed (patch by Kevin Ryde <user42@zip.com.au>)
(closes: #163745)
......@@ -516,7 +525,7 @@ gv (1:3.5.8-28) unstable; urgency=low
gv (1:3.5.8-27) unstable; urgency=high
* SECURITY: Fixed buffer overflow bug that allowed malformed
* SECURITY: Fixed buffer overflow bug that allowed malformed
PDF/Postscript files to cause arbitrary code to run with the
privileges of the current user (closes: #162830).
Thanks to Jan Niehusmann <jan@gondor.com> for the patch.
......@@ -534,7 +543,7 @@ gv (1:3.5.8-26) unstable; urgency=low
gv (1:3.5.8-25) unstable; urgency=high
* New maintainer
* Keep page markers in ToC when toggeling 'antialiasing'
* Keep page markers in ToC when toggeling 'antialiasing'
or some of the other flags (closes: #111039)
* Corrected handling of '-nosafer' and '-noquiet' (closes: #63223)
* Broken handling of malformed EPS files fixed (closes: #66059)
......@@ -643,16 +652,16 @@ gv (1:3.5.8-13) unstable; urgency=low
gv (1:3.5.8-12) unstable; urgency=low
* Corrected the doc-base control file (closes: Bug#31771)
* Removed explicit dwww support: doc-base supplies it
* Removed explicit dwww support: doc-base supplies it
(closes: Bug#31772)
-- Marco Pistore <pistore@di.unipi.it> Tue, 6 Jul 1999 22:38:32 +0200
gv (1:3.5.8-11) unstable; urgency=low
* Special characters of filenames are now quoted in the commands that
print, decompress and deal with PDF files (added function
quote_filename to file misc.c; modified files source/save.c and
* Special characters of filenames are now quoted in the commands that
print, decompress and deal with PDF files (added function
quote_filename to file misc.c; modified files source/save.c and
source/ps.c) (closes: Bug#30738)
* Removed double quotes from commands that print, decompress and deal
with PDF files: they are no more needed (modified files config.Unix
......@@ -663,16 +672,16 @@ gv (1:3.5.8-11) unstable; urgency=low
gv (1:3.5.8-10) unstable; urgency=low
* Changed scratch dir from ~ to /tmp in file config.Unix
* Changed scratch dir from ~ to /tmp in file config.Unix
(closes: Bug#30520).
* Changed print command in file config.Unix: the file name is
now quoted and gv prints also files with spaces (closes: Bug#30738).
* Changed command for uncompressing .gz files and for managing
PDF files in source/Imakefile so that the involved file names
PDF files in source/Imakefile so that the involved file names
are quoted (closes: Bug#30514).
* Modified ps.c, so that strings %dsc and %pdf can appear in the command
that extract the structure from PDF files. Changed the default command to
'pdf2dsc "%pdf" "%dsc"'.
'pdf2dsc "%pdf" "%dsc"'.
* Changed the default command that converts PDF files into PS files
to 'pdf2ps "%pdf" "%ps"'.
* Added support for quoted strings in function process_fork in file
......@@ -688,7 +697,7 @@ gv (1:3.5.8-9) unstable frozen; urgency=low
* Rewritten description in control file (now PDF support is
provided also by GNU gs, not only by Aladdin gs). For the same
reason, removed Suggests: gs-aladdin.
reason, removed Suggests: gs-aladdin.
* Modified save.c, so that strings %ps and %pdf can appear in the command
that converts PDF files into PS files. Changed the default command to
"pdf2ps %pdf %ps" that works both with gs 4 and with gs 5.
......@@ -709,7 +718,7 @@ gv (1:3.5.8-8) unstable; urgency=low
gv (1:3.5.8-7) unstable frozen; urgency=low
* I forgot to upload previous version also to FROZEN!
BRIAN, please include this in HAMM, since it avoids a conflict
BRIAN, please include this in HAMM, since it avoids a conflict
the BO version of fvwm-common.
-- Marco Pistore <pistore@di.unipi.it> Sun, 5 Apr 1998 19:17:58 +0200
......@@ -717,8 +726,8 @@ gv (1:3.5.8-7) unstable frozen; urgency=low
gv (1:3.5.8-6) unstable; urgency=low
* Added "Replaces: fvwm-common (<< 2.0.46-BETA-2)".
File /usr/X11R6/include/X11/pixmaps/mini-gv.xpm is present both in gv
and in old versions of package fvwm-common (for instance, the one in
File /usr/X11R6/include/X11/pixmaps/mini-gv.xpm is present both in gv
and in old versions of package fvwm-common (for instance, the one in
debian 1.3). The "Replaces: fvwm-common" allows to install the package
without the --force-overwrite flag. See Packaging 8.5.1 (thanks James).
......@@ -783,16 +792,16 @@ gv (3.4.3-1) unstable; urgency=low
* new upstream release including heavy improvements in look and feel as
well as several major improvements of the PostScript preprocessor and
several new features.
several new features.
* this version can no longer be used with standard Athena Widgets. This
release uses (and depends on) the shared Xaw3d library. By using the
-rpath option, the library has to be installed, but doesn't have to be
used as replacement for Xaw. It would be possible to link it
statically against Xaw3d (still dynamically linking all the rest).
If there are enough requests for this, I'll change the package to do
this.
For people compiling from source, simply use the other definition of
XAWLIB in config.Unix for the static version.
this.
For people compiling from source, simply use the other definition of
XAWLIB in config.Unix for the static version.
Note that the standard symlinks in /usr/X11R6/lib/Xaw3d may be
incorrect. You should check them first if you want to compile gv with
shared libXaw3d.
......@@ -846,7 +855,7 @@ gv (2.7b5-1) unstable; urgency=LOW
* First Debian release of the gv PostScript/PDF viewer.
several changes had to be made in order to support
standard Athena Widgets as well as Xaw3d.
standard Athena Widgets as well as Xaw3d.
* Regretfully there is currently no way to make a binary supporting
both kinds at the same time.
......
......@@ -2,16 +2,13 @@ Source: gv
Section: text
Priority: optional
Maintainer: Bernhard R. Link <brlink@debian.org>
Build-Depends: debhelper (>= 7), xaw3dg-dev, libxt-dev, libxmu-dev, libx11-dev, libxinerama-dev, autotools-dev
Standards-Version: 3.9.4
Build-Depends: debhelper (>= 12), xaw3dg-dev, libxt-dev, libxmu-dev, libx11-dev, libxinerama-dev, autotools-dev
Standards-Version: 4.3.0
Homepage: http://www.gnu.org/software/gv/
Vcs-Browser: http://anonscm.debian.org/gitweb?p=users/brlink/gv.git;a=summary
Vcs-Git: git://anonscm.debian.org/users/brlink/gv.git
Package: gv
Architecture: any
Depends: ghostscript-x, ${shlibs:Depends}, ${misc:Depends}
Recommends: xaw3dg (>= 1.5+E-18~)
Provides: postscript-viewer, pdf-viewer
Description: PostScript and PDF viewer for X
gv is a comfortable viewer of PostScript and PDF files for the X
......
?package(gv):needs="x11" section="Applications/Viewers" title="GV" \
icon="/usr/share/pixmaps/mini-gv.xpm" \
command="/usr/bin/gv" hints="PostScript,Documents"
#!/usr/bin/make -f
DEB_HOST_GNU_TYPE := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_BUILD_MAINT_OPTIONS=hardening=+all
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/buildflags.mk
ifeq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
BUILD_SYSTEM = --build $(DEB_BUILD_GNU_TYPE)
else
......@@ -12,21 +14,6 @@ CONFFLAGS = --enable-scrollbar-code --enable-signal-handler --without-libzio \
# some flags need to be given to make:
DIRFLAGS = appdefaultsdir=/etc/X11/app-defaults sysdocdir=/usr/share/doc
ifneq (,$(shell which dpkg-buildflags))
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
else
CFLAGS = -g
ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
CPPFLAGS =
LDFLAGS =
endif
CFLAGS += -Wall -Wmissing-prototypes -Wshadow
LDFLAGS += -Wl,-z,defs
ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
......@@ -73,7 +60,6 @@ binary-arch: build-arch-stamp
dh_installchangelogs ChangeLog
dh_installdocs AUTHORS NEWS README
dh_installinfo doc/gv.info
dh_installmenu
dh_installmime
dh_strip
dh_compress
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment