Release v0.43.0 to unstable

Signed-off-by: James Valleroy's avatarJames Valleroy <jvalleroy@mailbox.org>
parent 3173de94
plinth (0.43.0) unstable; urgency=medium
[ Michael Pimmer ]
* Backups: export and download archives in one step
* Backups: uploading and import with temporarily stored file
* Backups: Restore directly from archive
* Backups: Don't fail when borg doesn't find files to extract
* Backups: clean up exporting archives functionality
* Backups: relative paths for borg extract in action script
* Backups: fix test
* Backups: clean up forms, names and templates
* Functional tests: minor documentation changes
* Backups: Stream archive downloads/exports
* Backups: do not hardcode uploaded backup file path
* Backups: minor cleanups
* Backups: show free disk space on upload+restore page
* Backups: functional test to download and restore an archive
* Backups: minor adaption of upload file size warning
* Backups: minor fixes of functional tests
* Functional tests: check that browser waits for redirects to finish
* Functional tests: fix waiting for redirects
* Functional tests: assert that module installation succeeded
* Cherrypy: Do not limit maximum upload size
* Backups: Make Manifest a dict instead of a list
[ James Valleroy ]
* functional_tests: Remove backup export steps
* functional_tests: Remove remaining backup export steps
* functional_tests: Add sso tags
* upgrades: Internationalize string and apply minor formatting
[ Anthony Stalker ]
* Translated using Weblate (Czech)
[ Joseph Nuthalapati ]
* vagrant: Destroy Plinth development database when box is destroyed
* sso: Make auth-pubtkt tickets valid for 12 hours
* openvpn: Migration from easy-rsa 2 to 3
* openvpn: is-setup checks for non-empty dh.pem file
* openvpn: Always write the latest server configuration on setup
[ ssantos ]
* Translated using Weblate (Portuguese)
[ Robert Martinez ]
* Update module terminology improvements
* Incorporate feedback from MR
-- James Valleroy <jvalleroy@mailbox.org> Mon, 19 Nov 2018 17:25:31 -0500
plinth (0.42.0) unstable; urgency=medium
[ Robert Martinez ]
......
......@@ -18,4 +18,4 @@
Package init file.
"""
__version__ = '0.42.0'
__version__ = '0.43.0'
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment