Commit 86a5455b authored by Ben Hutchings's avatar Ben Hutchings

debian/control: Add !pkg.linux.nokernel to qualification for compiler build-deps

We use the default compiler provided by (cross-)build-essential for
userland, so the compiler build-dependencies are not needed when
the pkg.linux.nokernel profile is used.
parent 6c01fb14
......@@ -11,6 +11,8 @@ linux (4.19.16-2) UNRELEASED; urgency=medium
tools
* debian/rules.d: Delete now-unused recursive makefiles
* debian/rules.d/tools/perf/Makefile: Delete redundant arch/profile checks
* debian/control: Add !pkg.linux.nokernel to qualification for compiler
build-deps
-- Luca Boccassi <bluca@debian.org> Fri, 18 Jan 2019 19:09:06 +0000
......
......@@ -16,7 +16,7 @@ install-stem: vmlinuz
breaks: xserver-xorg-input-vmmouse (<< 1:13.0.99)
[relations]
gcc-8: gcc-8 (>= 8-20180123-1~) <!stage1 !cross>, gcc-8-x86-64-linux-gnu (>= 8-20180123-1~) <!stage1 cross>
gcc-8: gcc-8 (>= 8-20180123-1~) <!stage1 !cross !pkg.linux.nokernel>, gcc-8-x86-64-linux-gnu (>= 8-20180123-1~) <!stage1 cross !pkg.linux.nokernel>
headers%gcc-8: linux-compiler-gcc-8-x86
[amd64_description]
......
......@@ -140,7 +140,7 @@ recommends: apparmor
[relations]
# compilers
gcc-8: gcc-8 <!stage1 !cross>, gcc-8-@gnu-type-package@ <!stage1 cross>
gcc-8: gcc-8 <!stage1 !cross !pkg.linux.nokernel>, gcc-8-@gnu-type-package@ <!stage1 cross !pkg.linux.nokernel>
# initramfs-generators
initramfs-fallback: linux-initramfs-tool
......
......@@ -28,5 +28,5 @@ hardware: multiprocessor 64-bit PA-RISC
hardware-long: HP PA-RISC 64-bit SMP systems with support for more than 4 GB RAM
[relations]
gcc-8: gcc-8 <!stage1 !cross>, gcc-8-hppa-linux-gnu <!stage1 cross>, binutils-hppa64-linux-gnu <!stage1>, gcc-8-hppa64-linux-gnu <!stage1>
gcc-8: gcc-8 <!stage1 !cross !pkg.linux.nokernel>, gcc-8-hppa-linux-gnu <!stage1 cross !pkg.linux.nokernel>, binutils-hppa64-linux-gnu <!stage1 !pkg.linux.nokernel>, gcc-8-hppa64-linux-gnu <!stage1 !pkg.linux.nokernel>
......@@ -21,7 +21,7 @@ install-stem: vmlinuz
breaks: xserver-xorg-input-vmmouse (<< 1:13.0.99)
[relations]
gcc-8: gcc-8 (>= 8-20180123-1~) <!stage1 !cross>, gcc-8-x86-64-linux-gnu (>= 8-20180123-1~) <!stage1 cross>
gcc-8: gcc-8 (>= 8-20180123-1~) <!stage1 !cross !pkg.linux.nokernel>, gcc-8-x86-64-linux-gnu (>= 8-20180123-1~) <!stage1 cross !pkg.linux.nokernel>
headers%gcc-8: linux-compiler-gcc-8-x86
[686_description]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment