fix apt deprecation warning in ansible

parent f6f5cb8b
Pipeline #34886 passed with stage
in 2 minutes and 24 seconds
---
- name: install opsis related packages
apt:
name: "{{ item }}"
with_items:
- hdmi2usb-mode-switch
- openocd
- hdmi2usb-udev
- voctomix-outcasts
name: "{{ packages }}"
vars:
packages:
- hdmi2usb-mode-switch
- openocd
- hdmi2usb-udev
- voctomix-outcasts
- name: install opsis related packages from backports
apt:
name: "{{ item }}"
name: "{{ packages }}"
default_release: "{{ debian_version }}-backports"
state: latest
with_items:
- hdmi2usb-mode-switch
- openocd
- hdmi2usb-udev
- voctomix-outcasts
vars:
packages:
- hdmi2usb-mode-switch
- openocd
- hdmi2usb-udev
- voctomix-outcasts
when: ansible_distribution == 'Debian'
tags:
- skip_ansible_lint # using latest to upgrade to backports
- name: install serial terminal
apt:
name: "{{ item }}"
with_items: "{{ serial_terminal }}"
name: "{{ serial_terminal }}"
- name: push the script to connect to the opsis
template:
......
---
- name: install nginx packages
apt:
pkg: "{{ item }}"
name: "{{ packages }}"
default_release: "{{ debian_version }}-backports"
with_items:
vars:
packages:
- nginx-extras
- libnginx-mod-rtmp
- libnginx-mod-http-fancyindex
......@@ -13,7 +14,7 @@
- name: install ffmpeg
apt:
pkg: ffmpeg
name: ffmpeg
tags:
- streaming
......
---
- name: install nginx packages
apt:
pkg: "{{ item }}"
name: nginx-extras
default_release: "{{ debian_version }}-backports"
with_items:
- nginx-extras
notify: restart nginx
tags:
- streaming
- name: install geoip from contrib
apt:
pkg: "{{ item }}"
name: geoip-database-contrib
default_release: "{{ debian_version }}-backports"
with_items:
- geoip-database-contrib
tags:
- streaming
......
---
- name: install useful common packages
apt:
name: "{{ item }}"
with_items:
- ack-grep
- alsa-utils
- autossh
- curl
- emacs-nox
- etckeeper
- ethtool
- gdb
- git
- htop
- iftop
- iotop
- iperf
- ipython
- less
- lldpd
- lshw
- moreutils
- mtr-tiny
- net-tools
- psmisc
- python3-software-properties
- rsync
- screen
- strace
- tcpdump
- time
- tmux
- tree
- vim-nox
- vnstat
name: "{{ packages }}"
vars:
packages:
- ack-grep
- alsa-utils
- autossh
- curl
- emacs-nox
- etckeeper
- ethtool
- gdb
- git
- htop
- iftop
- iotop
- iperf
- ipython
- less
- lldpd
- lshw
- moreutils
- mtr-tiny
- net-tools
- psmisc
- python3-software-properties
- rsync
- screen
- strace
- tcpdump
- time
- tmux
- tree
- vim-nox
- vnstat
- name: install firmware packages
apt:
name: "{{ item }}"
with_items: "{{ firmware_packages }}"
name: "{{ firmware_packages }}"
---
- name: install required dependencies
apt:
pkg: "{{ item }}"
with_items:
name: "{{ packages }}"
vars:
packages:
- openssl
- python-openssl
tags:
......
......@@ -2,12 +2,13 @@
- name: Install VAAPI Packages
apt:
name: "{{ item }}"
with_items:
- gstreamer1.0-vaapi
- i965-va-driver
- intel-gpu-tools
- vainfo
name: "{{ packages }}"
vars:
packages:
- gstreamer1.0-vaapi
- i965-va-driver
- intel-gpu-tools
- vainfo
when: streaming.rtmp.vaapi
- name: RTMP streaming script
......
---
- name: install voctomix & related packages
apt:
name: "{{ item }}"
with_items:
- voctomix
- voctomix-outcasts
- gstreamer1.0-pulseaudio
name: "{{ packages }}"
vars:
packages
- voctomix
- voctomix-outcasts
- gstreamer1.0-pulseaudio
# sane sponsor loops require voctomix-outcasts >= 0.4.2-1
- name: install voctomix-outcasts from backports
apt:
name: "{{ item }}"
name: "{{ packages }}"
default_release: "{{ debian_version }}-backports"
state: latest
with_items:
- voctomix
- voctomix-core
- voctomix-gui
- voctomix-outcasts
vars:
packages:
- voctomix
- voctomix-core
- voctomix-gui
- voctomix-outcasts
when: ansible_distribution == 'Debian'
tags:
- skip_ansible_lint # using latest to upgrade to backports
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment