...
 
Commits (3)
postgis (2.2.2+dfsg-7) UNRELEASED; urgency=medium
* Limit supported PostgreSQL versions to exclude 9.6.
-- Markus Wanner <markus@bluegap.ch> Fri, 30 Sep 2016 14:06:31 +0200
postgis (2.2.2+dfsg-6) unstable; urgency=medium
* Downgrade the dependency from the extension package to the
scripts package to a recommendation, so the former becomes
co-installable with older versions, again.
-- Markus Wanner <markus@bluegap.ch> Fri, 30 Sep 2016 11:18:51 +0200
postgis (2.2.2+dfsg-5) unstable; urgency=medium
* Skip tests on sparc64, not a release architecture.
......
......@@ -102,9 +102,10 @@ Description: PostGIS "Lightweight Geometry" library - Development files
Package: postgresql-9.5-postgis-2.2
Depends: ${shlibs:Depends}, postgresql-9.5,
postgresql-9.5-postgis-2.2-scripts, liblwgeom-2.2-5,
liblwgeom-2.2-5,
${misc:Depends}
Recommends: postgresql-contrib-9.5
Recommends: postgresql-9.5-postgis-2.2-scripts,
postgresql-contrib-9.5
Suggests: postgis
Breaks: postgis (<< 1.2.1)
Architecture: any
......
......@@ -102,9 +102,10 @@ Description: PostGIS "Lightweight Geometry" library - Development files
Package: postgresql-PGVERSION-postgis-2.2
Depends: ${shlibs:Depends}, postgresql-PGVERSION,
postgresql-PGVERSION-postgis-2.2-scripts, liblwgeom-2.2-5,
liblwgeom-2.2-5,
${misc:Depends}
Recommends: postgresql-contrib-PGVERSION
Recommends: postgresql-PGVERSION-postgis-2.3-scripts,
postgresql-contrib-PGVERSION
Suggests: postgis
Breaks: postgis (<< 1.2.1)
Architecture: any
......
# Note: Listing each version individually triggers an issue on
# distributions where the default version of Postgres isn't the newest
# one. '9.0+' circumvents that issue with current pg_buildext.
#
9.1+
9.1
9.2
9.3
9.4
9.5