...
 
Commits (2)
python-stetl (1.2+ds-2) UNRELEASED; urgency=medium
* Bump Standards-Version to 4.2.0, no changes.
* Drop autopkgtests to test installability & module import.
* Add lintian override for testsuite-autopkgtest-missing.
-- Bas Couwenberg <sebastic@debian.org> Sun, 05 Aug 2018 20:54:36 +0200
......
# Python 3 is not supported yet: https://github.com/geopython/stetl/issues/23
python-stetl source: python-foo-but-no-python3-foo python-stetl
# Not worth the effort
testsuite-autopkgtest-missing
# Test installability
Depends: @
Test-Command: /bin/true
# Test module import (Python 2)
Depends: python-all, python-stetl
Test-Command: set -e ; for py in $(pyversions -r 2>/dev/null) ; do cd "$ADTTMP" ; echo "Testing with $py:" ; $py -c "import stetl; print(stetl)" ; done