Commit 212f2f0e authored by Andreas Metzler's avatar Andreas Metzler

Fix perl 5.18 build failure

23_perl5.18.diff from upstream HG. - Fix perl 5.18 build failure.
Closes: #719867
parent f02800c9
enblend-enfuse (4.0+dfsg-6) unstable; urgency=medium
* 23_perl5.18.diff from upstream HG. - Fix perl 5.18 build failure.
Closes: #719867
-- Andreas Metzler <ametzler@debian.org> Sun, 18 Aug 2013 18:06:11 +0200
enblend-enfuse (4.0+dfsg-5) unstable; urgency=medium
* Texinfo 5.1 fixes/workarounds:
......
Description: Fix Perl warning "Use of qw(...) as parentheses..."
See upstream HG 824:937e07c89c8b
Author: Chris <cspiel@users.sourceforge.net>
Origin: upstream
Bug-Debian: http://bugs.debian.org/719867
Forwarded: not-needed
--- enblend-enfuse-4.0+dfsg.orig/src/DefaultSig.pm
+++ enblend-enfuse-4.0+dfsg/src/DefaultSig.pm
@@ -19,7 +19,7 @@ use Sys::Hostname;
our %HAVE_MODULE;
BEGIN {
- foreach my $module qw(Time::Zone) {
+ foreach my $module (qw(Time::Zone)) {
eval "use $module ()"; # import, but keep module's original name space for clarity
$HAVE_MODULE{$module} = $EVAL_ERROR eq '';
}
......@@ -8,3 +8,4 @@
20_semilog.diff
21_inline_foo.diff
22_fixpdfbuild.diff
23_perl5.18.diff
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment