Commit 517003b8 authored by Kartik Mistry's avatar Kartik Mistry 🇮🇳

Imported Upstream version 1.18.5

parent 5061a022
commit 2571bf4a364834b01fb915d02528c322ff0b2622
commit e5db3a4cbb8dbe0f535d4bcd01eb446d16362188
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
AuthorDate: 2014-03-30
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
Update copyright year to 2014
commit ab39ea4546d3247b5e02de91868cc3bd99f40d10
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
CommitDate: 2014-03-30
Update NEWS
commit dcf98d519f2a1d4a1ab221e581570ffcb56b16c5
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
Fix crash if unpause failed before assigning BtProgressInfoFile object
commit b706722c592f9be1e69782a637bce1cd6ca364c3
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
Fix unitest crash
commit b98a5d62b4ad6a2177db198354489509a235cfc9
commit 305ef84e5de5acd0281ae9636ad1239886e60b8f
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
AuthorDate: 2014-03-30
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
CommitDate: 2014-03-30
Bump up version number to 1.18.3
commit a052dd9ad08e28122ec881abdd4d8056ddad1175
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2014-01-05
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2014-01-05
Update NEWS
commit 35ed2505fad543f253d37f783f01746a7e4fe068
Author: Nils Maier <maierman@web.de>
AuthorDate: 2014-01-02
Commit: Nils Maier <maierman@web.de>
CommitDate: 2014-01-02
makerelease-osx: Do not hardcode -Os into CXXFLAGS
commit 1ca0712455651ff8cb37df735a67e591b7c4546d
Author: Nils Maier <maierman@web.de>
AuthorDate: 2013-12-31
Commit: Nils Maier <maierman@web.de>
CommitDate: 2014-01-02
Enable and check PIE in makerelease-osx
Position-independent Executables enable Address Space Layout
Randomization (ASLR) style security features, which makes it harder to
exploit certain security vulnerablities.
Closes GH-174
Bump up version number to 1.18.5
commit 8216bdba796802aea5c4c18ed1df934892eb1e7d
commit f0473dc34dfb4d36b92aee49a6373704582338b5
Author: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
AuthorDate: 2013-12-31
AuthorDate: 2014-03-30
Commit: Tatsuhiro Tsujikawa <tatsuhiro.t@gmail.com>
CommitDate: 2013-12-31
CommitDate: 2014-03-30
Fix bug that numOpenFile_ is not reduced when MultiDiskAdaptor is deleted
Ignore error when setting DSCP value
This bug caused assertion error in RequestGroupMan::ensureMaxOpenFileLimit
Setting DSCP is additional feature and failure to enable it should not
abort download entirely. This change fixes the bug that windows build
does not perform bittorrent downloads.
......@@ -12,8 +12,8 @@ without warranty of any kind.
Basic Installation
==================
Briefly, the shell commands `./configure; make; make install' should
configure, build, and install this package. The following
Briefly, the shell command `./configure && make && make install'
should configure, build, and install this package. The following
more-detailed instructions are generic; see the `README' file for
instructions specific to this package. Some packages provide this
`INSTALL' file but do not implement all of the features documented
......
# Makefile.in generated by automake 1.14 from Makefile.am.
# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
......@@ -757,9 +757,10 @@ distcheck: dist
&& dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
&& am__cwd=`pwd` \
&& $(am__cd) $(distdir)/_build \
&& ../configure --srcdir=.. --prefix="$$dc_install_base" \
&& ../configure \
$(AM_DISTCHECK_CONFIGURE_FLAGS) \
$(DISTCHECK_CONFIGURE_FLAGS) \
--srcdir=.. --prefix="$$dc_install_base" \
&& $(MAKE) $(AM_MAKEFLAGS) \
&& $(MAKE) $(AM_MAKEFLAGS) dvi \
&& $(MAKE) $(AM_MAKEFLAGS) check \
......
aria2 1.18.5
============
Release Note
------------
This release fixes BitTorrent download failure on Mingw build.
Changes
-------
* Ignore error when setting DSCP value
Setting DSCP is additional feature and failure to enable it should
not abort download entirely. This change fixes the bug that windows
build does not perform bittorrent downloads.
aria2 1.18.4
============
Release Note
------------
This release adds new RPC authorization mechanism using --rpc-secret
option. The existing --rpc-user and --rpc-passwd options are now
deprecated, and all applications using RPC API is strongly encouraged
to migrate to the new mechanism. See RPC INTERFACE section in aria2
manual page for the details. The new RPC method, aria2.saveSession,
was added, which tells aria2 server to save session file immediately.
There are several enhancements and bug fixes. See the changes for the
details.
Changes
-------
* Added support for RPC channel encryption in aria2rpc
Patch from David Macek
* Add aria2.saveSession RPC method
This method saves the current session to a file specified by
--save-session option. This method returns "OK" if it succeeds.
* Add numStoppedTotal key to aria2.getGlobalStat() RPC method response
It shows the number of stopped downloads in the current session and
not capped by --max-download-result option. On the other hand, the
existing numStopped key also shows the number of stopped downloads,
but it is capped by --max-download-result option.
* Better handling of 30x HTTP status codes
Reference: http://greenbytes.de/tech/tc/httpredirects/
* Implement new RPC authorization using --rpc-secret option
Add future deprecation warning to --rpc-user and --rpc-passwd. Warn
if neither --rpc-secret nor a combination of --rpc-user/rpc-passwd
is set.
* Add --enable-color option to enable/disable terminal color output
* Add DSCP support
* gnutls: Don't fail handshake if returned error is not fatal
* Add workaround GnuTLS bug with OCSP status extension and
non-blocking socket
GnuTLS version 3.1.3 - 3.1.18 and 3.2.0 - 3.2.8, inclusive, has this
bug. For these versions, we disable OCSP status extension.
* Make GnuTLS log level dependent on the aria2 ones
aria2 1.18.3
============
......
......@@ -625,8 +625,10 @@ $ make check
</div>
<div class="section" id="cross-compiling-windows-binary">
<h1>Cross-compiling Windows binary</h1>
<p>In this section, we describe how to build a Windows binary using
a mingw-w64 cross-compiler on Debian Linux.</p>
<p>In this section, we describe how to build a Windows binary using a
mingw-w64 (<a class="reference external" href="http://mingw-w64.sourceforge.net/">http://mingw-w64.sourceforge.net/</a>) cross-compiler on Debian
Linux. The MinGW (<a class="reference external" href="http://www.mingw.org/">http://www.mingw.org/</a>) may not be able to build
aria2.</p>
<p>Basically, after compiling and installing depended libraries, you can
do cross-compile just passing appropriate <tt class="docutils literal"><span class="pre">--host</span></tt> option and
specifying <tt class="docutils literal">CPPFLAGS</tt>, <tt class="docutils literal">LDFLAGS</tt> and <tt class="docutils literal">PKG_CONFIG_LIBDIR</tt>
......@@ -704,7 +706,7 @@ command-line for x86_64 Linux host.</p>
</li>
</ul>
<p>Before running <tt class="docutils literal"><span class="pre">android-config</span></tt> and <tt class="docutils literal"><span class="pre">android-make</span></tt>,
<tt class="docutils literal">$ANDOIRD_HOME</tt> environment variable must be set to point to the
<tt class="docutils literal">$ANDROID_HOME</tt> environment variable must be set to point to the
correct path.</p>
<p>After <tt class="docutils literal"><span class="pre">android-config</span></tt>, run <tt class="docutils literal"><span class="pre">android-make</span></tt> to compile sources.</p>
</div>
......
......@@ -277,8 +277,10 @@ aria2 uses CppUnit for automated unit testing. To run the unit test::
Cross-compiling Windows binary
------------------------------
In this section, we describe how to build a Windows binary using
a mingw-w64 cross-compiler on Debian Linux.
In this section, we describe how to build a Windows binary using a
mingw-w64 (http://mingw-w64.sourceforge.net/) cross-compiler on Debian
Linux. The MinGW (http://www.mingw.org/) may not be able to build
aria2.
Basically, after compiling and installing depended libraries, you can
do cross-compile just passing appropriate ``--host`` option and
......@@ -364,7 +366,7 @@ environment variable which must fulfill the following conditions:
``$ANDROID_HOME/usr/local``.
Before running ``android-config`` and ``android-make``,
``$ANDOIRD_HOME`` environment variable must be set to point to the
``$ANDROID_HOME`` environment variable must be set to point to the
correct path.
After ``android-config``, run ``android-make`` to compile sources.
......
# generated automatically by aclocal 1.14 -*- Autoconf -*-
# generated automatically by aclocal 1.14.1 -*- Autoconf -*-
# Copyright (C) 1996-2013 Free Software Foundation, Inc.
......@@ -35,7 +35,7 @@ AC_DEFUN([AM_AUTOMAKE_VERSION],
[am__api_version='1.14'
dnl Some users find AM_AUTOMAKE_VERSION and mistake it for a way to
dnl require some minimum version. Point them to the right macro.
m4_if([$1], [1.14], [],
m4_if([$1], [1.14.1], [],
[AC_FATAL([Do not call $0, use AM_INIT_AUTOMAKE([$1]).])])dnl
])
......@@ -51,7 +51,7 @@ m4_define([_AM_AUTOCONF_VERSION], [])
# Call AM_AUTOMAKE_VERSION and AM_AUTOMAKE_VERSION so they can be traced.
# This function is AC_REQUIREd by AM_INIT_AUTOMAKE.
AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
[AM_AUTOMAKE_VERSION([1.14])dnl
[AM_AUTOMAKE_VERSION([1.14.1])dnl
m4_ifndef([AC_AUTOCONF_VERSION],
[m4_copy([m4_PACKAGE_VERSION], [AC_AUTOCONF_VERSION])])dnl
_AM_AUTOCONF_VERSION(m4_defn([AC_AUTOCONF_VERSION]))])
......
......@@ -45,6 +45,9 @@
/* Define to 1 if XML-RPC support is enabled. */
#undef ENABLE_XML_RPC
/* Define to 1 if the system has the type `struct timespec'. */
#undef HAVE_A2_STRUCT_TIMESPEC
/* Define to 1 if you have the `alarm' function. */
#undef HAVE_ALARM
......@@ -420,9 +423,6 @@
/* Define to 1 if you have the `strtoull' function. */
#undef HAVE_STRTOULL
/* Define to 1 if the system has the type `struct timespec'. */
#undef HAVE_STRUCT_TIMESPEC
/* Define to 1 if you have the <sys/ioctl.h> header file. */
#undef HAVE_SYS_IOCTL_H
......
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
# Generated by GNU Autoconf 2.69 for aria2 1.18.3.
# Generated by GNU Autoconf 2.69 for aria2 1.18.5.
#
# Report bugs to <t-tujikawa@users.sourceforge.net>.
#
......@@ -590,8 +590,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='aria2'
PACKAGE_TARNAME='aria2'
PACKAGE_VERSION='1.18.3'
PACKAGE_STRING='aria2 1.18.3'
PACKAGE_VERSION='1.18.5'
PACKAGE_STRING='aria2 1.18.5'
PACKAGE_BUGREPORT='t-tujikawa@users.sourceforge.net'
PACKAGE_URL='http://aria2.sourceforge.net/'
......@@ -1559,7 +1559,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
\`configure' configures aria2 1.18.3 to adapt to many kinds of systems.
\`configure' configures aria2 1.18.5 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
......@@ -1630,7 +1630,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
short | recursive ) echo "Configuration of aria2 1.18.3:";;
short | recursive ) echo "Configuration of aria2 1.18.5:";;
esac
cat <<\_ACEOF
......@@ -1819,7 +1819,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
aria2 configure 1.18.3
aria2 configure 1.18.5
generated by GNU Autoconf 2.69
Copyright (C) 2012 Free Software Foundation, Inc.
......@@ -2827,7 +2827,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
It was created by aria2 $as_me 1.18.3, which was
It was created by aria2 $as_me 1.18.5, which was
generated by GNU Autoconf 2.69. Invocation command line was
$ $0 $@
......@@ -3806,7 +3806,7 @@ fi
# Define the identity of the package.
PACKAGE='aria2'
VERSION='1.18.3'
VERSION='1.18.5'
cat >>confdefs.h <<_ACEOF
......@@ -7643,7 +7643,7 @@ ia64-*-hpux*)
rm -rf conftest*
;;
x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
# Find out which ABI we are using.
echo 'int i;' > conftest.$ac_ext
......@@ -7668,7 +7668,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
;;
esac
;;
ppc64-*linux*|powerpc64-*linux*)
powerpc64le-*)
LD="${LD-ld} -m elf32lppclinux"
;;
powerpc64-*)
LD="${LD-ld} -m elf32ppclinux"
;;
s390x-*linux*)
......@@ -7687,7 +7690,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
x86_64-*linux*)
LD="${LD-ld} -m elf_x86_64"
;;
ppc*-*linux*|powerpc*-*linux*)
powerpcle-*)
LD="${LD-ld} -m elf64lppc"
;;
powerpc-*)
LD="${LD-ld} -m elf64ppc"
;;
s390*-*linux*|s390*-*tpf*)
......@@ -12716,9 +12722,9 @@ case "$host" in
*mingw*)
win_build=yes
LIBS="$LIBS -lws2_32 -lwsock32 -lgdi32 -lwinmm -liphlpapi -lpsapi"
# Deactivate __USE_MINGW_ANSI_STDIO because it causes lots of errors for
# PRId64.
CPPFLAGS="-D__USE_MINGW_ANSI_STDIO=0 $CPPFLAGS"
# C++ headers defines __USE_MINGW_ANSI_STDIO to 1 unconditionally.
# We have to use it as well nonetheless.
CPPFLAGS="-D__USE_MINGW_ANSI_STDIO=1 $CPPFLAGS"
;;
esac
......@@ -19872,13 +19878,13 @@ See \`config.log' for more details" "$LINENO" 5; }
fi
use_md=""
if test "x$have_appletls" == "xyes"; then
if test "x$have_appletls" = "xyes"; then
use_md="apple"
$as_echo "#define USE_APPLE_MD 1" >>confdefs.h
else
if test "x$have_wintls" == "xyes"; then
if test "x$have_wintls" = "xyes"; then
use_md="windows"
$as_echo "#define USE_WINDOWS_MD 1" >>confdefs.h
......@@ -19913,7 +19919,7 @@ $as_echo "#define USE_INTERNAL_MD 1" >>confdefs.h
fi
# Define variables based on the result of the checks for libraries.
if test "x$have_appletls" = "xyes" || test "x$have_wintls" == "xyes" || test "x$have_libgnutls" = "xyes" || test "x$have_openssl" = "xyes"; then
if test "x$have_appletls" = "xyes" || test "x$have_wintls" = "xyes" || test "x$have_libgnutls" = "xyes" || test "x$have_openssl" = "xyes"; then
have_ssl="yes"
$as_echo "#define ENABLE_SSL 1" >>confdefs.h
......@@ -21241,14 +21247,12 @@ _ACEOF
fi
ac_fn_cxx_check_type "$LINENO" "struct timespec" "ac_cv_type_struct_timespec" "$ac_includes_default"
if test "x$ac_cv_type_struct_timespec" = xyes; then :
cat >>confdefs.h <<_ACEOF
#define HAVE_STRUCT_TIMESPEC 1
_ACEOF
have_timespec=yes
else
have_timespec=no
fi
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether byte ordering is bigendian" >&5
......@@ -21676,6 +21680,12 @@ rm -rf conftest*
fi
if test "x$have_timespec" = "xyes"; then
$as_echo "#define HAVE_A2_STRUCT_TIMESPEC 1" >>confdefs.h
fi
# Checks for library functions.
mkdir_p="$MKDIR_P"
......@@ -25423,8 +25433,7 @@ else
HAVE_GAI_STRERROR_FALSE=
fi
if test "x$have_clock_gettime" != "xyes"; then
if true; then
if test "x$have_clock_gettime" != "xyes"; then
HAVE_TIMEGETTIME_TRUE=
HAVE_TIMEGETTIME_FALSE='#'
else
......@@ -25432,7 +25441,6 @@ else
HAVE_TIMEGETTIME_FALSE=
fi
fi
;;
*)
if false; then
......@@ -26539,7 +26547,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
This file was extended by aria2 $as_me 1.18.3, which was
This file was extended by aria2 $as_me 1.18.5, which was
generated by GNU Autoconf 2.69. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
......@@ -26606,7 +26614,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
aria2 config.status 1.18.3
aria2 config.status 1.18.5
configured by $0, generated by GNU Autoconf 2.69,
with options \\"\$ac_cs_config\\"
......
......@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
#
AC_PREREQ([2.67])
AC_INIT([aria2],[1.18.3],[t-tujikawa@users.sourceforge.net],[aria2],[http://aria2.sourceforge.net/])
AC_INIT([aria2],[1.18.5],[t-tujikawa@users.sourceforge.net],[aria2],[http://aria2.sourceforge.net/])
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
......@@ -29,9 +29,9 @@ case "$host" in
*mingw*)
win_build=yes
LIBS="$LIBS -lws2_32 -lwsock32 -lgdi32 -lwinmm -liphlpapi -lpsapi"
# Deactivate __USE_MINGW_ANSI_STDIO because it causes lots of errors for
# PRId64.
CPPFLAGS="-D__USE_MINGW_ANSI_STDIO=0 $CPPFLAGS"
# C++ headers defines __USE_MINGW_ANSI_STDIO to 1 unconditionally.
# We have to use it as well nonetheless.
CPPFLAGS="-D__USE_MINGW_ANSI_STDIO=1 $CPPFLAGS"
;;
esac
......@@ -462,11 +462,11 @@ if test "x$with_libcares" = "xyes"; then
fi
use_md=""
if test "x$have_appletls" == "xyes"; then
if test "x$have_appletls" = "xyes"; then
use_md="apple"
AC_DEFINE([USE_APPLE_MD], [1], [What message digest implementation to use])
else
if test "x$have_wintls" == "xyes"; then
if test "x$have_wintls" = "xyes"; then
use_md="windows"
AC_DEFINE([USE_WINDOWS_MD], [1], [What message digest implementation to use])
else
......@@ -491,7 +491,7 @@ else
fi
# Define variables based on the result of the checks for libraries.
if test "x$have_appletls" = "xyes" || test "x$have_wintls" == "xyes" || test "x$have_libgnutls" = "xyes" || test "x$have_openssl" = "xyes"; then
if test "x$have_appletls" = "xyes" || test "x$have_wintls" = "xyes" || test "x$have_libgnutls" = "xyes" || test "x$have_openssl" = "xyes"; then
have_ssl="yes"
AC_DEFINE([ENABLE_SSL], [1], [Define to 1 if ssl support is enabled.])
AM_CONDITIONAL([ENABLE_SSL], true)
......@@ -667,10 +667,16 @@ AC_TYPE_UINT64_T
AC_TYPE_UINT8_T
AC_TYPE_PID_T
AC_C_VOLATILE
AC_CHECK_TYPES([ptrdiff_t, struct timespec])
AC_CHECK_TYPES([ptrdiff_t])
AC_CHECK_TYPE([struct timespec], [have_timespec=yes], [have_timespec=no])
AC_C_BIGENDIAN
AC_SYS_LARGEFILE
if test "x$have_timespec" = "xyes"; then
AC_DEFINE([HAVE_A2_STRUCT_TIMESPEC], [1],
[Define to 1 if the system has the type `struct timespec'.])
fi
# Checks for library functions.
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.18])
......@@ -847,9 +853,7 @@ case "$host" in
AM_CONDITIONAL([HAVE_GETADDRINFO], true)
dnl defined in ws2tcpip.h, but missing in C:\mingw\lib\libws2_32.a
AM_CONDITIONAL([HAVE_GAI_STRERROR], false)
if test "x$have_clock_gettime" != "xyes"; then
AM_CONDITIONAL([HAVE_TIMEGETTIME], true)
fi
AM_CONDITIONAL([HAVE_TIMEGETTIME], [test "x$have_clock_gettime" != "xyes"])
;;
*)
AM_CONDITIONAL([MINGW_BUILD], false)
......
# Makefile.in generated by automake 1.14 from Makefile.am.
# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
......
......@@ -12,8 +12,8 @@ without warranty of any kind.
Basic Installation
==================
Briefly, the shell commands `./configure; make; make install' should
configure, build, and install this package. The following
Briefly, the shell command `./configure && make && make install'
should configure, build, and install this package. The following
more-detailed instructions are generic; see the `README' file for
instructions specific to this package. Some packages provide this
`INSTALL' file but do not implement all of the features documented
......
# Makefile.in generated by automake 1.14 from Makefile.am.
# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
......@@ -652,9 +652,10 @@ distcheck: dist
&& dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
&& am__cwd=`pwd` \
&& $(am__cd) $(distdir)/_build \
&& ../configure --srcdir=.. --prefix="$$dc_install_base" \
&& ../configure \
$(AM_DISTCHECK_CONFIGURE_FLAGS) \
$(DISTCHECK_CONFIGURE_FLAGS) \
--srcdir=.. --prefix="$$dc_install_base" \
&& $(MAKE) $(AM_MAKEFLAGS) \
&& $(MAKE) $(AM_MAKEFLAGS) dvi \
&& $(MAKE) $(AM_MAKEFLAGS) check \
......
# generated automatically by aclocal 1.14 -*- Autoconf -*-
# generated automatically by aclocal 1.14.1 -*- Autoconf -*-
# Copyright (C) 1996-2013 Free Software Foundation, Inc.
......@@ -35,7 +35,7 @@ AC_DEFUN([AM_AUTOMAKE_VERSION],
[am__api_version='1.14'
dnl Some users find AM_AUTOMAKE_VERSION and mistake it for a way to
dnl require some minimum version. Point them to the right macro.
m4_if([$1], [1.14], [],
m4_if([$1], [1.14.1], [],
[AC_FATAL([Do not call $0, use AM_INIT_AUTOMAKE([$1]).])])dnl
])
......@@ -51,7 +51,7 @@ m4_define([_AM_AUTOCONF_VERSION], [])
# Call AM_AUTOMAKE_VERSION and AM_AUTOMAKE_VERSION so they can be traced.
# This function is AC_REQUIREd by AM_INIT_AUTOMAKE.
AC_DEFUN([AM_SET_CURRENT_AUTOMAKE_VERSION],
[AM_AUTOMAKE_VERSION([1.14])dnl
[AM_AUTOMAKE_VERSION([1.14.1])dnl
m4_ifndef([AC_AUTOCONF_VERSION],
[m4_copy([m4_PACKAGE_VERSION], [AC_AUTOCONF_VERSION])])dnl
_AM_AUTOCONF_VERSION(m4_defn([AC_AUTOCONF_VERSION]))])
......
......@@ -5652,7 +5652,7 @@ ia64-*-hpux*)
rm -rf conftest*
;;
x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
# Find out which ABI we are using.
echo 'int i;' > conftest.$ac_ext
......@@ -5677,7 +5677,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
;;
esac
;;
ppc64-*linux*|powerpc64-*linux*)
powerpc64le-*)
LD="${LD-ld} -m elf32lppclinux"
;;
powerpc64-*)
LD="${LD-ld} -m elf32ppclinux"
;;
s390x-*linux*)
......@@ -5696,7 +5699,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
x86_64-*linux*)
LD="${LD-ld} -m elf_x86_64"
;;
ppc*-*linux*|powerpc*-*linux*)
powerpcle-*)
LD="${LD-ld} -m elf64lppc"
;;
powerpc-*)
LD="${LD-ld} -m elf64ppc"
;;
s390*-*linux*|s390*-*tpf*)
......
# Makefile.in generated by automake 1.14 from Makefile.am.
# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
......
# Makefile.in generated by automake 1.14 from Makefile.am.
# Makefile.in generated by automake 1.14.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994-2013 Free Software Foundation, Inc.
......
......@@ -70,7 +70,7 @@
# compiler: $LTCC
# compiler flags: $LTCFLAGS
# linker: $LD (gnu? $with_gnu_ld)
# $progname: (GNU libtool) 2.4.2 Debian-2.4.2-1.3
# $progname: (GNU libtool) 2.4.2 Debian-2.4.2-1.7
# automake: $automake_version
# autoconf: $autoconf_version
#
......@@ -80,7 +80,7 @@
PROGRAM=libtool
PACKAGE=libtool
VERSION="2.4.2 Debian-2.4.2-1.3"
VERSION="2.4.2 Debian-2.4.2-1.7"
TIMESTAMP=""
package_revision=1.3337
......
......@@ -1312,7 +1312,7 @@ ia64-*-hpux*)
rm -rf conftest*
;;
x86_64-*kfreebsd*-gnu|x86_64-*linux*|ppc*-*linux*|powerpc*-*linux*| \
x86_64-*kfreebsd*-gnu|x86_64-*linux*|powerpc*-*linux*| \
s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
# Find out which ABI we are using.
echo 'int i;' > conftest.$ac_ext
......@@ -1333,7 +1333,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
;;
esac
;;
ppc64-*linux*|powerpc64-*linux*)
powerpc64le-*)
LD="${LD-ld} -m elf32lppclinux"
;;
powerpc64-*)
LD="${LD-ld} -m elf32ppclinux"
;;
s390x-*linux*)
......@@ -1352,7 +1355,10 @@ s390*-*linux*|s390*-*tpf*|sparc*-*linux*)
x86_64-*linux*)
LD="${LD-ld} -m elf_x86_64"
;;
ppc*-*linux*|powerpc*-*linux*)
powerpcle-*)
LD="${LD-ld} -m elf64lppc"