Commit bf418c97 authored by Markus Wanner's avatar Markus Wanner

Bump compat version to 11 and S-V to 4.2.1.

Drop obsolete B-D on autotools-dev, use dh_installsystemd.
parent 14a77c53
......@@ -8,8 +8,11 @@ courier (1.0.1-1) UNRELEASED; urgency=medium
* Extend patch 0018-Fix-default-configuration-for-Debian.patch with
the piddir addition proposed by Willi Mann. Closes: #875696.
* d/control: tighten dependency on courier-unicode, eliminate obsolete
build dependency dh-systemd.
* d/rules: drop `--with autotools-dev`.
build dependencies autotools-dev and dh-systemd.
* Bump debian/compat to 11.
* Bump S-V to 4.2.1.
* d/rules: drop `--with autotools-dev` and `--with systemd`, use
dh_installsystemd, instead.
* Drop patch 0025-Use-SOURCE_DATE_EPOCH.., it got applied upstream.
* Drop lintian overrides: possible-gpl-code-linked-with-openssl is
no longer required, since courier is built against gnutls. And
......@@ -28,7 +31,7 @@ courier (1.0.1-1) UNRELEASED; urgency=medium
[ Dimitri John Ledkov ]
* Disable gnutls OPENPGP certificates. Closes: #879530.
-- Markus Wanner <markus@bluegap.ch> Mon, 22 Oct 2018 20:12:02 +0200
-- Markus Wanner <markus@bluegap.ch> Sun, 11 Nov 2018 19:13:52 +0100
courier (0.78.0-2) unstable; urgency=medium
......
......@@ -2,11 +2,10 @@ Source: courier
Section: mail
Priority: optional
Maintainer: Markus Wanner <markus@bluegap.ch>
Standards-Version: 3.9.6
Standards-Version: 4.2.1
Build-Depends: automake,
autotools-dev,
courier-authlib-dev (>= 0.66.4-5~),
debhelper (>= 9),
debhelper (>= 11),
default-libmysqlclient-dev,
dh-autoreconf,
dh-exec,
......
......@@ -46,7 +46,7 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
SED_VERSION=sed -ne 's/^Version: \(.*\)/\1/p'
%:
dh $@ --with autoreconf --with systemd
dh $@ --with autoreconf
override_dh_autoreconf:
find $(CURDIR) -name Makefile.in -delete
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment