Commit f7815f50 authored by Craig Small's avatar Craig Small

Update to debhelper-compat 12

Use debhelper compat level 12
Remove the compat files, no longer required
Build-depend on buildhelper-compat 12 Closes: #919179
parent 7c0ad025
dh-make (2.201901) unstable; urgency=medium
* dh_makefont call dh_make correctly Closes: #914564
* Use debhelper-compat and move to compat level 12 Closes: #919179
-- Craig Small <csmall@debian.org> Tue, 15 Jan 2019 21:38:15 +1100
-- Craig Small <csmall@debian.org> Mon, 26 Nov 2018 22:27:40 +1100
dh-make (2.201802) UNRELEASED; urgency=medium
[ Paul Wise ]
......
......@@ -2,7 +2,7 @@ Source: dh-make
Section: devel
Priority: optional
Maintainer: Craig Small <csmall@debian.org>
Build-Depends: debhelper (>= 11), dh-python, python3-all
Build-Depends: debhelper-compat (= 12), dh-python, python3-all
Standards-Version: 4.1.3
Vcs-Browser: https://salsa.debian.org/debian/dh-make
Vcs-Git: https://salsa.debian.org/debian/dh-make.git
......
......@@ -14,7 +14,7 @@ from shutil import copy2
from email.utils import formatdate
from enum import Enum
__version__ = '2.201802'
__version__ = '2.201901'
__dhlib__ = '/usr/share/debhelper/dh_make'
policy_version = '4.1.3'
......@@ -205,7 +205,7 @@ def get_subs(args):
'YEAR': time.strftime('%Y'),
'USERNAME': get_username(),
'POLICY': policy_version,
'BUILD_DEPS': ['debhelper (>= 11)'],
'BUILD_DEPS': ['debhelper-compat (= 12)'],
'DH_ADDON': '',
'SOURCE_EXTRADOCS': '',
'RULES_START_TEXT': '',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment