1. 12 Jan, 2019 6 commits
    • Chris Lamb's avatar
      Import Debian changes 1:0.51-3.2 · 7352a7a7
      Chris Lamb authored
      fastforward (1:0.51-3.2) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Make the build reproducible. (Closes: #776972)
      7352a7a7
    • Adrian Bunk's avatar
      Import Debian changes 1:0.51-3.1 · 421578d1
      Adrian Bunk authored
      fastforward (1:0.51-3.1) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Add patch from Harry Sintonen to fix segfaults on 64bit.
          (Closes: #859327)
      421578d1
    • Adrian Bunk's avatar
      Import Debian changes 1:0.51-3.1~deb9u1 · df0b123c
      Adrian Bunk authored
      fastforward (1:0.51-3.1~deb9u1) stretch; urgency=medium
      
        * Non-maintainer upload.
        * Rebuild for stretch.
      
      fastforward (1:0.51-3.1) unstable; urgency=medium
      
        * Non-maintainer upload.
        * Add patch from Harry Sintonen to fix segfaults on 64bit.
          (Closes: #859327)
      df0b123c
    • Gerrit Pape's avatar
      Import Debian changes 1:0.51-3 · f0f5776f
      Gerrit Pape authored
      fastforward (1:0.51-3) unstable; urgency=low
      
        * debian/rules: install the fastforward's newaliases program as
          /usr/sbin/qmail-newaliases to avoid conflict.
        * debian/sbin: remove; obsolete.
        * debian/fastforward.README.Debian: talk about newaliases being
          installed as /usr/sbin/qmail-newaliases, and the qmail-run package.
        * debian/rules: install newaliases.1 man page as
          /usr/share/man/man1/qmail-newaliases.1.
        * debian/rules: no longer install ~alias/.qmail-default (again).
        * debian/fastforward.postinst, debian/fastforward.postrm: create
          ~alias/.qmail-default if it doesn't exist; remove on purge.
      
      fastforward (1:0.51-2) unstable; urgency=low
      
        * debian/rules: install ~alias/.qmail-default again.
        * debian/fastforward.examples: remove; obsolete.
        * debian/fastforward.preinst, debian/fastforward.postrm: no longer
          add/remove diversion of Debian qmail's /usr/sbin/newaliases
          program.
        * debian/control: Standards-Version: 3.8.0.1.
      
      fastforward (1:0.51-1) unstable; urgency=low
      
        * debian/rules: remove target configure:; use glibc by default instead
          of dietlibc; new target patch: apply diff from debian/diff/; install
          into /var/lib/qmail/ instead of /var/qmail/; target binary-arch: run
          dpkg-shlibdeps; target clean: remove debian/substvars; target build:
          set conf-qmail, restore orig in target clean:.
        * debian/diff/0001-error.h-cdb_seek.c-include-errno.h-instead-of.diff:
          new: error.h, cdb_seek.c: '#include <errno.h>' instead of 'extern
          int errno;'.
        * debian/implicit: update to revision a09db2e.
        * debian/gcc/: remove; obsolete.
        * debian/fastforward.docs: remove INSTALL.
        * debian/rules: no longer install ~alias/.qmail-default.
        * debian/fastforward.conffiles: remove; obsolete.
        * debian/fastforward.examples: new; add debian/qmail-default.
        * debian/control: no longer Build-Depends: dietlibc; no longer
          Depends: qmail, but Recommends:; Depends: ${shlibs:Depends};
          Build-Depends: groff-base; Standards-Version: 3.7.3.0; update short
          and long descriptions.
        * debian/copyright: upstream sources and debian diff is in the public
          domain.
        * debian/fastforward.README.Debian: redo.
        * debian/changelog: add epoch 1 to supersede unofficial package.
        * upload to Debian/main (closes: #484765).
        * debian/fastforward.preinst, debian/fastforward.postrm: add/remove
          diversion of Debian qmail's /usr/sbin/newaliases program.
      
      fastforward (0.51-zarge2) sarge; urgency=low
      
        * build against sarge's dietlibc-dev (0.28-3).
      
      fastforward (0.51-zarge1) sarge; urgency=low
      
        * debian/rules: minor cleanup.
        * debian/implicit: update to revision 1.10.
      
      fastforward (0.51-zarge0.3) sarge; urgency=low
      
        * debian/control: no longer Build-Depends: dephelper; remove
          Standards-Version.
        * debian/rules: stop using debhelper, use implicit rules.
        * debian/implicit: new; implicit Makefile rules.
        * debian/README.Debian, debian/conffiles, debian/docs: rename to
          fastforward.*.
        * debian/dirs, debian/links.in: remove; obsolete.
        * debian/copyright: minor.
      
      fastforward (0.51-zarge0.2) sarge; urgency=low
      
        * use diet libc.
        * debian/rules: new target configure: set up diet program as c compiler
          wrapper; conditionally overwrite PATH to have diet program used as c
          compiler wrapper; minor cleanup.
        * debian/gcc/gcc*: new; diet program as c compiler wrapper.
        * debian/control: Build-Depends: dietlibc-dev; no longer Depends:
          ${shlibs:Depends}.
      
      fastforward (0.51-woody1) woody; urgency=low
      
        * bump version for release.
      
      fastforward (0.51-woody0.2) woody; urgency=low
      
        * debian/rules: use numeric uids and gids to avoid build-dependency
          on qmail-uids-gids.
      
      fastforward (0.51-woody0.1) woody; urgency=low
      
        * woody package; new Standards-Version: 3.5.2.
        * postinst script removed.
      f0f5776f
    • David Kimdon's avatar
      Import Debian changes 0.51-5 · 9384815d
      David Kimdon authored
      fastforward (0.51-5) unstable; urgency=low
      
        * add manpage (closes: #96501) 
        * build cleanups.
        * maintainer field set to packages@qa.debian.org
      
      fastforward (0.51-4) unstable; urgency=low
      
        * Orphaned.
      
      fastforward (0.51-3) unstable; urgency=low
      
        * Use /usr/sbin/qmail-queue instead of /var/qmail/bin/qmail-queue.
          Thanks to Tomoaki Ishikawa. Closes: bug#43974
        * FHS compliance.
      
      fastforward (0.51-2) unstable; urgency=low
      
        * Got rid of debhelper dependency
      
      fastforward (0.51-1) unstable; urgency=low
      
        * Initial Release.
      9384815d
    • Dmitry Bogatov's avatar
      Import Upstream version 0.51 · bbef731d
      Dmitry Bogatov authored
      bbef731d