1. 01 Oct, 2018 1 commit
  2. 27 Aug, 2018 1 commit
  3. 20 Apr, 2018 1 commit
  4. 17 Apr, 2018 1 commit
  5. 16 Apr, 2018 4 commits
  6. 29 Sep, 2017 8 commits
    • Sylvestre Ledru's avatar
      Missing build dep · c51c6db8
      Sylvestre Ledru authored
      c51c6db8
    • Sylvestre Ledru's avatar
      * Update the Qt5 (Closes: #874894) · b9f8df46
      Sylvestre Ledru authored
      * Update compat mode to 9 (was 5)
      b9f8df46
    • Sylvestre Ledru's avatar
      * New upstream release · e77f496e
      Sylvestre Ledru authored
      * Use the fork on github (Closes: #854021) (LP: #1571787)
      e77f496e
    • Sylvestre Ledru's avatar
      Updated version 5.3.7 from 'upstream/5.3.7' · ea7a1c27
      Sylvestre Ledru authored
      with Debian dir 0e9e04a3dc90d3748a1925c731aff537009d5f07
      ea7a1c27
    • Sylvestre Ledru's avatar
      New upstream version 5.3.7 · b77d7ddf
      Sylvestre Ledru authored
      b77d7ddf
    • Sylvestre Ledru's avatar
      * Use the fork on github (Closes: #854021) · 66e19917
      Sylvestre Ledru authored
      * Move the maintenance to pkg-collab
      * Standards-Version updated to 4.1.0
      * Update the upstream url to the github project
      * Update uscan to download from github
      66e19917
    • Sylvestre Ledru's avatar
      Import Upstream version 5.1.0 · 795af12c
      Sylvestre Ledru authored
      795af12c
    • Sylvestre Ledru's avatar
      Import Debian changes 5.1.0-4 · a1017332
      Sylvestre Ledru authored
      fwbuilder (5.1.0-4) unstable; urgency=low
      
        * Associate fwb extension to fwbuilder. Thanks to Alexander Schlarb for doing
          all the work (LP: #1200790)
        * Recommends rcs from fwbuilder (Closes: #701108)
        * Standards-Version updated to 3.9.4
      
      fwbuilder (5.1.0-3) unstable; urgency=low
      
        * generation of firewall was missing due to the removal of fwblookup
          Merci beaucoup à Roland Mas (Closes: #678006)
      
      fwbuilder (5.1.0-2) unstable; urgency=low
      
        * ACK NMU (thanks)
        * Fix the FTBFS under HURD
      
      fwbuilder (5.1.0-1.1) unstable; urgency=low
      
        * Non maintainer upload
        * Fix build failure with GCC 4.7 (Ilya Barygin). Closes: #674349.
      
      fwbuilder (5.1.0-1) unstable; urgency=low
      
        * New upstream release
        * Standards-Version updated to version 3.9.3
      
      fwbuilder (5.0.1-1) unstable; urgency=low
      
        * New upstream release
      
      fwbuilder (5.0.0-1) unstable; urgency=low
      
        * New upstream release
      
      fwbuilder (4.2.2-1) unstable; urgency=low
      
        * New upstream release (important regression)
      
      fwbuilder (4.2.1-1) unstable; urgency=low
      
        * New upstream release
        * netfilter-extensions-source added as suggests of fwbuilder 
         (Closes: #605613)
        * Migration files were not installed (Closes: #626276)
      
      fwbuilder (4.2.0-1) unstable; urgency=low
      
        * New upstream release (no longer need the separate package libfwbuilder)
        * Standards-Version updated to version 3.9.2
        * Update of the watch file
        * Switch to dpkg-source 3.0 (quilt) format
      
      fwbuilder (4.1.3-2) unstable; urgency=low
      
        * Upload in unstable
      
      fwbuilder (4.1.3-1) experimental; urgency=low
      
        * New upstream release
        * Missing files added (Closes: #601877)
      
      fwbuilder (4.1.2-1) unstable; urgency=low
      
        * New upstream release
      
      fwbuilder (4.1.1-1) unstable; urgency=low
      
        * New upstream release (Closes: #594428)
      
      fwbuilder (4.1.0-1) unstable; urgency=low
      
        * New upstream release 
      
      fwbuilder (4.0.2-2) unstable; urgency=low
      
        * Install some missing files (Closes: #591769)
      
      fwbuilder (4.0.2-1) unstable; urgency=low
      
        * New upstream release (Closes: #580760)
        * Standards-Version updated to version 3.9.1
      
      fwbuilder (3.0.7-1) unstable; urgency=high
      
        * New upstream version
        * This new version fixes a security issue described in the bug report.
          This problem is likely to be in the package libfwbuilder but since both
          packages are tightly connected, need to upload also fwbuilder
          (Closes: #547390)
        * fwbuilder-dbg moved to Section: debug
      
      fwbuilder (3.0.6-1) unstable; urgency=low
      
        * New upstream version
        * Change of my email address since I am now DD
        * Removal of Torsten on his request
        * Standards-Version updated to 3.8.3
        * DM-Upload-Allowed removed
      
      fwbuilder (3.0.5-2) unstable; urgency=low
      
        * One more time, I forgot to update the version of the libfwbuilder-dev dep
      
      fwbuilder (3.0.5-1) unstable; urgency=low
      
        * Artificial separation of fwbuilder-{linux,bsd,cisco} removed on the 
          advice of upstream
        * New upstream version
      
      fwbuilder (3.0.4-2) unstable; urgency=low
      
        * Increase of the dep on libfwbuilder (3.0.3 => 3.0.4) (Closes: #522038)
      
      fwbuilder (3.0.4-1) unstable; urgency=low
      
        * New upstream version (damn it, I should have waited a few hours)
      
      fwbuilder (3.0.3-2) unstable; urgency=low
      
        * Misc depends added 
        * Missing files in the doc (LP: #350673)
        * Standards-Version updated to 3.8.1
        * fwbuilder-doc added to Recommands of fwbuilder
      
      fwbuilder (3.0.3-1) unstable; urgency=low
      
        * New upstream release
      
      fwbuilder (3.0.2-1) unstable; urgency=low
      
        * New upstream release
        * Remove patch gcc-4.4.diff that has been applied upstream.
        * Update patch debug.diff.
      
      fwbuilder (3.0.1-2) unstable; urgency=low
      
        * Add --with-qmake=qmake-qt4 to the configure argument list.
          (Closes: #505651)
        * Clean up debian/rules.
        * Update Build-Depends: libfwbuilder-dev (>= 3.0.1).
        * Add patch gcc-4.4.diff provided by Martin Michlmayr.
          (Closes: #505654)
      
      fwbuilder (3.0.1-1) unstable; urgency=low
      
        * New upstream version (Closes: #501419)
        * Patch tmpdirsecurity.diff removed (script removed upstream)
      
      fwbuilder (3.0.0-1) unstable; urgency=low
      
        * New upstream version (Closes: #498640, #255071)
        * Missing (= ${binary:Version}) for fwbuilder-dbg (Closes: #497752)
      
      fwbuilder (2.1.19-6) unstable; urgency=low
      
        * debian/* cleanup
      
      fwbuilder (2.1.19-5) unstable; urgency=low
      
        * Fix a security issue. Thanks to Thijs Kinkhorst. (Closes: #496406)
      
      fwbuilder (2.1.19-4) unstable; urgency=low
      
        * Add binary package fwbuilder-dbg that ships debugging symbols.
        * Add patch debug.diff to avoid stripping the binaries during installation.
        * Bump up Standards-Version: 3.8.0 (no changes needed).
      
      fwbuilder (2.1.19-3) unstable; urgency=low
      
        * Still issues with gcc 4.3
      
      fwbuilder (2.1.19-2) unstable; urgency=low
      
        * Remove the dependency to libantlr-dev since the recoginition languages tools are included by fwbuilder and builds now with gcc-4.3. (Closes: #483236)
      
      fwbuilder (2.1.19-1) unstable; urgency=low
      
        * new upstream release
        * Remove our patch that has been applied upstream.
      
      fwbuilder (2.1.18-2) unstable; urgency=low
      
        * Add DM-Upload-Allowed: yes to enable uploads by Sylvestre.
        * Install tools fwb_compile_all, fwb_install and its man pages.
          (Closes: #477074)
        * Add new package fwbuilder-cisco.
      
      fwbuilder (2.1.18-1) unstable; urgency=low
      
        [ Sylvestre Ledru ]
        * New upstream version (Closes: #438084)
      
        [ Torsten Werner ]
        * Switch to cdbs.
        * Clean up Build-Depends.
        * Fix manpage fwbedit(1).
      
      fwbuilder (2.1.17-3) unstable; urgency=low
      
        * Add Build-Depends: libantlr-dev. (Closes: #474673)
      
      fwbuilder (2.1.17-2) unstable; urgency=low
      
        * Clean up (Build-)Depends, Conflicts, and Replaces.
        * Remove all extra arguments when calling dpkg-gencontrol via dh_gencontrol.
        * Replace some dbs files by plain debhelper.
        * Update and reformat the README files. (Closes: #347370)
        * Add a desktop file thanks to Stephan Windmüller. (Closes: #465472)
        * Disable stripping of binaries in install.sh. (Closes: #436910)
      
      fwbuilder (2.1.17-1) unstable; urgency=low
      
        [ Sylvestre Ledru ]
        * New upstream version
          (Closes: #417685, #376527, #419753, #409262, #470402, #255071)
        * Update of the watch file (Closes: #449727)
        * Cleanup lintian warnings
        * Fields Homepage, Vcs-Svn and Vcs-Browser added
        * Standards-Version updated to 3.7.3
        * Torsten and Sylvestre added as (co-)maintainers
      
        [ Torsten Werner ]
        * Switch to debhelper 5.
      
      fwbuilder (2.1.8-1) unstable; urgency=low
      
        * New upstream version (Closes: #3276527, #382596, #275450)
        * Fix libfwbuilder dependency (Closes: #341803)
        * Accepting NMUs (Closes: #385831, #376622)
      
      fwbuilder (2.0.9-1.2) unstable; urgency=low
      
        * NMU.
        * Drop build dependency on g++-3.4. Closes: #385831.
      
      fwbuilder (2.0.9-1.1) unstable; urgency=low
      
        * Non-maintainer upload.
        * Remove the unneccesary Build-Depends on automake. (Closes: #376622)
      
      fwbuilder (2.0.9-1) unstable; urgency=low
      
        * New upstream version released (Closes: #327826).
        * Clean-up build environment to clear lintian issues
        * Surprise having fwbuilder-2.0.9 to build with libfwbuilder-2.0.9
          solves the impatient bug reporting of FTBFS (Closes: #338113).
        * Rebuilding after libfwbuilder 2.0.9-2 corrects the shlibs to keep
          incompatible libfwbuilder libs from being installed so fwbuilder
          doesn't segfault on XSLT transformations it doesn't have 
          available (Closes: #338293).
        * Uploading this package early with no real testing to please Steve
          Langasek and Roland Stigge. I'll fix any issues after my wedding!
      
      fwbuilder (2.0.7-2) unstable; urgency=high
      
        * Corrects build issues from C++ ABI transition and Qt/KDE
          (Closes: #327963, #327365, #324874, #327017).
      
      fwbuilder (2.0.7-1.1) unstable; urgency=low
      
        * Non-maintainer upload.
        * Rebuild for Qt/KDE and gcc 4.0 transition 
          (Closes: #327963, #327017, #324874, #327365)
      
      fwbuilder (2.0.7-1) unstable; urgency=low
      
        * New upstream release (Closes: #293405)
        * src/gui/SSHPIX.cpp includes errno.h (Closes: #274817)
        * Issue of empty example/ directory as mentioned in #257706
          has been addressed and is correctly included with fwbuilder-common.
          As the full wishlist has not been completed I'm leaving it open. If 
          Someone wants to create a userland script that can take the 
          fwbuiler default file and init.d script from examples/ along with 
          the generated fwbuilder script and generate a .DEB for install as
          Goswin has proposed I will evaluate and include in next upload.
      
      fwbuilder (2.0.3-2) unstable; urgency=low
      
        * Correct libfwbuilder-dev Build-Depend (Closes: #276533)
      
      fwbuilder (2.0.3-1) unstable; urgency=medium
      
        * New upstream bug fix release
      
      fwbuilder (2.0.2-2) unstable; urgency=high
      
        * Rebuild against modified libfwbuilder6 shlibs (Closes: 270293)
      
      fwbuilder (2.0.2-1) unstable; urgency=high
      
        * New upstream bug fix release (Closes: 268898)
        * Removed doc++ Build-Dep (Closes: 270002)
        * Removed Debian patches
      
      fwbuilder (2.0.1-2) unstable; urgency=high
      
        * Added fwbuilder version depend on -common (Closes: 268897)
        * Urgency set to high to fix RC bug for testing
      
      fwbuilder (2.0.1-1) unstable; urgency=high
      
        * New upstream release (Closes: 261978)
        * Example files return (Closes: 254908)
        * Release fixes seg fault crashes (Closes: 266615, 256085)
        * Updated watch file
      
      fwbuilder (1.1.2-3) unstable; urgency=low
      
        * This it the Make-James-Troup-Happy upload. You will find that all
          the policy compiler packaging has changed into 2 packages either
          fwbuilder-linux or fwbuilder-bsd. These replace all the separate
          packages for the different policy compilers based on firewall 
          platform which James considered "bloat" in rejecting the 1.1.2-2
          upload.
        * This also corrects the conflict issue in fwbuilder-common when
          upgrading from an older version (Closes: #248583)
      
      fwbuilder (1.1.2-2) unstable; urgency=low
      
        * Added Conflicts in fwbuilder-common against older versions
          of fwbuilder that contained the arch-indep files (Closes: #248583)
        * Created fwbuilder-ipfw package for missing policy compiler
          from build
        * Created fwbuilder-doc package to include provided documentation
          from upstream
        * Renamed fwbuilder-ipf to fwbuilder-ipfilter to remove possible
          confusion with fwbuilder-ipfw
        * Removed old fwbuilder-iptables transition package from build
        * GUI diaglogs for Mac OS X and FreeBSD ipfw not installed properly
          with fwbuilder causing errors when selecting those options for a
          given firewall
      
      fwbuilder (1.1.2-1) unstable; urgency=low
      
        * New upstream version (Closes: #229084)
        * Moved arch-dep modules from /usr/share to /usr/lib via patch
          01fhs_modules_path.diff (Closes: #234249)
        * Unable to reproduce the seg fault problem reported and the BTS
          does not contain enough information after 3 months to track any
          source down so closing. If more conclusive details can be given
          I will re-investigate. It may have been fixed along with the NMU
          that corrected 203776. (Closes: #229774)
        * Added entry to README.Debian regarding upgrading the data file
          from earlier versions. (Closes: #228803)
      
      fwbuilder (1.1.1-1) unstable; urgency=low
      
        * Accept NMU done by Brian Bassett (Closes: #223651)
        * Created fwbuilder-common and moved common arch-indep files
          to install there rather than arch-dep fwbuilder. This does
          handle half of 233349 but not the portion covered by 234249
          so I'm considering this one done and leaving the other open
          until I can patch the code to move the modules (Closes: #233349)
        * Suggests for iproute on fwbuilder-ipt (Closes: #219441)
        * Hope rebuild my fix seg faults reported but not willing to
          close the bug yet.
      
      fwbuilder (1.1.1-0.1) unstable; urgency=low
      
        * NMU.
        * New upstream version. (Closes: #222025)
          + Fixes libxml2 2.6.2 breakage. (Closes: #203776, #220830, #222478)
        * Clean up Build-Depends line; no longer requires any GNOME components.
      
      fwbuilder (1.0.10-2) unstable; urgency=low
      
        * Patch to fwbuilder-ipt OSConfigurator_linux24.cc to fix bashism in
      		generated script (Closes: #200258, #200259)
      
      fwbuilder (1.0.10-1) unstable; urgency=low
      
        * New upstream version
        * Libtool library linking issues resolved (Closes: #186032)
        * fwbuilder-doc package removed (Closes: #186245, #157352)
        * Corrected problem with fwblookup (Closes: #183914)
        * Patched contributed fwbuilder init.d with provided patch by
          Robert Lindgren <robert@orcafat.com> see README.Debian
          for more details
        * Cleaned up lintian errors
      
      fwbuilder (1.0.9-1) unstable; urgency=low
      
        * New upstream version
        * Rebuilt with new libsigc++ (Closes: #176801)
        * Rebuilt with new libgtkmm (Closes: #180037, #179743)
      
      fwbuilder (1.0.8-1) unstable; urgency=low
      
        * New upstream version 
        * Rebuilt with new libxml2 (Closes: #170908, #170918)
      
      fwbuilder (1.0.7-1) unstable; urgency=low
      
        * New upstream version (Closes: #167319)
      
      fwbuilder (1.0.5-1) unstable; urgency=low
      
        * New upstream version 
        * Fixes build issues on HPPA (Closes: #148701, #133683)
      
      fwbuilder (1.0.4-1) unstable; urgency=low
      
        * New upstream version (Closes: #155551, #155553)
        * New build environment
        * Fixes problem in fwbuilder-ipt (Closes: #151876)
        * Fixes dependency issue with fwbuilder-ipt (Closes: #154734)
      
      fwbuilder (1.0.3-1) unstable; urgency=low
      
        * New upstream version
      
      fwbuilder (1.0.2-3) unstable; urgency=low
      
        * Reworked conflicts with libfwbuilder-dev for fwbuilder-dev
      
      fwbuilder (1.0.2-2) unstable; urgency=low
      
        * Corrected Conflicts with libfwbuilder-dev (Closes: #148730)
      
      fwbuilder (1.0.2-1) unstable; urgency=low
      
        * New upstream release
      
      fwbuilder (1.0.0-1) unstable; urgency=low
      
        * New upstream release
        * Removed fwbuilder-ipfilter from build as requested by upstream as
          it is not properly maintained at this time 
      
      fwbuilder (0.9.9-2) unstable; urgency=low
      
        * Typo/spelling correction in debian/control (Closes: #124655) 
      
      fwbuilder (0.9.9-1) unstable; urgency=low
      
        * New upstream bug fix release 
      
      fwbuilder (0.9.8-1) unstable; urgency=low
      
        * New upstream bug fix release 
      
      fwbuilder (0.9.7-3) unstable; urgency=low
      
        * Corrections in dependencies on libfwbuilder and backends 
      
      fwbuilder (0.9.7-2) unstable; urgency=low
      
        * Corrections to debian/control for Build-Depends 
      
      fwbuilder (0.9.7-1) unstable; urgency=low
      
        * New upstream version 
      
      fwbuilder (0.9.6-2) unstable; urgency=low
      
        * Fixed bug with fwbuilder-doc package not containing any of the
        documents as the upstream Makefile install installed using versioned
        doc directory 
      
      fwbuilder (0.9.6-1) unstable; urgency=low
      
        * New upstream release October 16, 2001 (closes: #116605)
      
      fwbuilder (0.9.5-2) unstable; urgency=low
      
        * Included upstream patch to correct conflict with BIND9 namespace 
        conflict with resolv.h
      
      fwbuilder (0.9.5-1) unstable; urgency=low
      
        * New upstream release August 6, 2001 (closes: #107716)
      
      fwbuilder (0.9.2-3) unstable; urgency=low
      
        * Bug fix for dependency (Closes: #109122) 
      
      fwbuilder (0.9.2-2) unstable; urgency=low
      
        * Bug fix for ports (Closes: #105317) 
      
      fwbuilder (0.9.2-1) unstable; urgency=low
      
        * New upstream release June 30, 2001 (closes: #103640)
      
      fwbuilder (0.9.1-3) unstable; urgency=low
      
        * Corrected build to include bug-buddy support
      
      fwbuilder (0.9.1-2) unstable; urgency=low
      
        * Minor change to conflict with obsolete fwbuilder-ipchains package
        * Added lintian overrides
        * Added simple manpage for fwbuilder
      
      fwbuilder (0.9.1-1) unstable; urgency=low
      
        * New upstream release May 11, 2001 (closes: #97205) 
        * Removal of fwbuilder-ipchains as upstream is no longer supporting
      
      fwbuilder (0.8.7-1) unstable; urgency=low
      
        * Initial release.
      a1017332