Commit 663a082d authored by Javier Merino Cacho's avatar Javier Merino Cacho

Upgrade debhelper compat to 9

parent bfd9ba2d
hgsubversion (1.6.3-2) UNRELEASED; urgency=medium
* Add autopkgtest
* Upgrade debhelper compat to 9
-- Javi Merino <vicho@debian.org> Tue, 26 Aug 2014 13:10:31 -0700
......
......@@ -5,7 +5,7 @@ Maintainer: Qijiang Fan <fqj1994@gmail.com>
Uploaders:
Javi Merino <vicho@debian.org>,
Build-Depends:
debhelper (>= 7.0.50~),
debhelper (>= 9),
python (>= 2.6.6-3~),
mercurial,
subversion,
......
#!/usr/bin/make -f
MODULE_DIR = usr/lib/$(shell pyversions -d)/site-packages/
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
build:
dh_auto_test
%:
dh $@ --with python2
clean:
dh clean
find $(CURDIR) -type f -name '*\.py[co]' -delete
install: build
dh_installdirs $(MODULE_DIR)/hgsubversion
cp hgsubversion/ -r debian/hgsubversion/$(MODULE_DIR)
binary-indep: install
dh binary-indep --with python2
binary-arch:
build-arch: build
build-indep: build
binary: binary-indep binary-arch
patch unpatch:
dh_quilt_$(@)
.PHONY: build clean binary-indep binary-arch binary install patch unpatch
# "make all" gives instructions on how to install it *and* fails. No
# need to build anything, so just skip it.
override_dh_auto_build:
# There's a Makefile but "make install" does absolutely nothing
override_dh_auto_install:
python setup.py install --root $(CURDIR)/debian/hgsubversion --install-layout=deb
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment