Commit 41740db2 authored by Mark Hymers's avatar Mark Hymers

Try to build against Qt4 (qt3 is still needed for some reason)

Signed-off-by: Mark Hymers's avatarMark Hymers <mhy@debian.org>
parent c4104ca9
......@@ -3,7 +3,7 @@ Section: science
Priority: optional
Maintainer: Mark Hymers <mhy@debian.org>
Uploaders: Chris Lamb <lamby@debian.org>
Build-Depends: debhelper (>= 7), libvtk5-dev, libqt3-mt-dev, cmake, libncurses5-dev, libtiff4-dev, quilt, chrpath
Build-Depends: debhelper (>= 7), libvtk5-dev, libqt3-mt-dev, libqt4-dev, cmake, libncurses5-dev, libtiff4-dev, quilt, chrpath
Standards-Version: 3.8.3
Homepage: http://home.fnal.gov/~gnedin/IFRIT/
Vcs-Browser: http://git.debian.org/git/users/mhy/ifrit.git
......
......@@ -25,8 +25,8 @@ build: build-stamp
build-stamp: $(QUILT_STAMPFN)
dh_testdir
cd build && VTKDIR=/usr/lib/vtk-5.2 cmake -D DESIRED_QT_VERSION:STRING=3 \
-D QT_LIBRARY_DIR:STRING=/usr/lib/qt3 \
-D QT_QMAKE_EXECUTABLE:STRING=/usr/bin/qmake-qt3 \
-D QT_LIBRARY_DIR:STRING=/usr/lib/qt4 \
-D QT_QMAKE_EXECUTABLE:STRING=/usr/bin/qmake-qt4 \
-D CMAKE_EXE_LINKER_FLAGS:STRING=-Wl,--as-needed \
-D CMAKE_COLOR_MAKEFILE:BOOL=FALSE \
.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment