Commit a6ce4220 authored by Peter Pentchev's avatar Peter Pentchev

Add zstandard support using libzstd.

parent af9212f6
......@@ -4,6 +4,7 @@ libarchive (3.3.3-1) UNRELEASED; urgency=medium
* Declare compliance with Debian Policy 4.2.1 with no changes.
* Drop the Lintian overrides related to B-D: debhelper-compat -
Lintian 2.5.98 no longer emits these warnings and errors.
* Build with zstd compression support.
[ Andreas Henriksson ]
* New upstream release.
......@@ -17,7 +18,7 @@ libarchive (3.3.3-1) UNRELEASED; urgency=medium
- iso9660-validate-directory-record-length.patch
* Update libarchive13.symbols
-- Andreas Henriksson <andreas@fatal.se> Sat, 01 Dec 2018 18:02:58 +0100
-- Peter Pentchev <roam@debian.org> Sat, 15 Dec 2018 01:40:02 +0200
libarchive (3.2.2-5) unstable; urgency=medium
......
......@@ -7,6 +7,7 @@ Build-Depends: debhelper-compat (= 11),
liblz4-dev,
liblzma-dev,
libxml2-dev,
libzstd-dev,
zlib1g-dev,
libacl1-dev [!hurd-any],
e2fslibs-dev,
......@@ -60,6 +61,7 @@ Description: Multi-format archive and compression library (development files)
* uudecode (read only)
* separate command-line compressors with fixed-signature auto-detection
* xz and lzma (read and write using liblzma)
* zstandard (read and write using libzstd)
.
This package provides the files necessary for development with libarchive.
......@@ -101,6 +103,7 @@ Description: Multi-format archive and compression library (shared library)
* uudecode (read only)
* separate command-line compressors with fixed-signature auto-detection
* xz and lzma (read and write using liblzma)
* zstandard (read and write using libzstd)
.
This package provides the libarchive shared library.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment