...
 
Commits (3)
libepoxy (1.5.2-0.2) unstable; urgency=medium
* Non-maintainer upload
* libepoxy-dev Depends on libgl1-mesa-dev and libegl1-mesa-dev.
Those packages provide gl.pc and egl.pc, which are depended on by
epoxy.pc since 1.5.2 (Closes: #909173)
* Work around #874077 by creating an Xvfb screen where GLX can work
-- Simon McVittie <smcv@debian.org> Wed, 19 Sep 2018 10:39:51 +0100
libepoxy (1.5.2-0.1) unstable; urgency=medium
* Non-maintainer upload
......
......@@ -21,7 +21,10 @@ Package: libepoxy-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libepoxy0 (= ${binary:Version}), ${misc:Depends}
Depends: libegl1-mesa-dev,
libepoxy0 (= ${binary:Version}),
libgl1-mesa-dev,
${misc:Depends}
Description: OpenGL function pointer management library- development
It hides the complexity of dlopen(), dlsym(), glXGetProcAddress(),
eglGetProcAddress(), etc. from the app developer, with very little
......
......@@ -7,9 +7,9 @@
# See https://bugs.debian.org/874077
override_dh_auto_test:
ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
xvfb-run dh_auto_test
xvfb-run -a -s "-screen 0 1024x768x24" dh_auto_test
else
-xvfb-run dh_auto_test
-xvfb-run -a -s "-screen 0 1024x768x24" dh_auto_test
endif
# No symbols for udebs, specify the highest version from symbols file:
......