...
 
Commits (4)
......@@ -2,6 +2,13 @@ libpipeline (1.5.0-2) UNRELEASED; urgency=medium
* Move VCS to salsa.debian.org.
* Adjust git-dpm tagging configuration.
* Upgrade to debhelper v10.
* Set Rules-Requires-Root: no.
* Simplify debian/rules using /usr/share/dpkg/architecture.mk and
/usr/share/dpkg/pkg-info.mk.
* Drop priority to optional, per Lintian's
excessive-priority-for-library-package tag; a higher priority can be
handled using overrides if necessary.
-- Colin Watson <cjwatson@debian.org> Mon, 22 Jan 2018 11:12:05 +0000
......
Source: libpipeline
Section: libs
Priority: important
Priority: optional
Maintainer: Colin Watson <cjwatson@debian.org>
Standards-Version: 4.0.0
Build-Depends: dpkg-dev (>= 1.17.14), debhelper (>= 9.20141010), pkg-config, check <!nocheck>, dh-autoreconf, automake (>= 1:1.10)
Build-Depends: dpkg-dev (>= 1.17.14), debhelper (>= 10~), pkg-config, check <!nocheck>, automake (>= 1:1.10)
Homepage: http://libpipeline.nongnu.org/
Vcs-Git: https://salsa.debian.org/debian/libpipeline.git
Vcs-Browser: https://salsa.debian.org/debian/libpipeline
Rules-Requires-Root: no
Package: libpipeline1
Architecture: any
......@@ -20,7 +21,6 @@ Description: pipeline manipulation library
Package: libpipeline-dev
Section: libdevel
Priority: optional
Architecture: any
Depends: ${misc:Depends}, libpipeline1 (= ${binary:Version})
Multi-Arch: same
......
#! /usr/bin/make -f
%:
dh $@ --builddirectory=debian/build --with=autoreconf --parallel
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/pkg-info.mk
%:
dh $@ --builddirectory=debian/build
export DEB_BUILD_MAINT_OPTIONS := hardening=+bindnow,+pie
......@@ -23,8 +25,7 @@ override_dh_auto_install:
override_dh_installdocs:
dh_installdocs --link-doc=libpipeline1
VERSION_MINOR = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p' | \
cut -d. -f1,2).0
VERSION_MINOR = $(shell echo "$(DEB_VERSION_UPSTREAM)" | cut -d. -f1,2).0
override_dh_makeshlibs:
dh_makeshlibs -V'libpipeline1 (>= $(VERSION_MINOR))' -- -c4