Imported Debian patch 1:0.4.0+dfsg1-9

parent 35d9dfd8
libvisual-plugins (1:0.4.0+dfsg1-9) unstable; urgency=medium
* Bumped DH level to 10.
* debian/control:
- Added libesd0-dev and libjack-dev to Build-Depends field to increase
the features to libvisual-plugins.
- Bumped Standards-Version to 3.9.8.
- Updated the Vcs-* fields to use https instead of http and git.
* debian/copyright: updated the packaging copyright years.
* debian/patches/:
- Added the suffix .patch in all patches.
- Added 95_fix_spelling.patch to fix a spelling error in a final binary.
* debian/rules: added --disable-gstreamer-plugin option to
override_dh_auto_configure target to avoid a FTBFS, since gstreamer-0.8
is no longer available in Debian. (Closes: #839331)
* debian/watch: bumped to version 4.
-- Joao Eriberto Mota Filho <eriberto@debian.org> Sun, 09 Oct 2016 18:53:31 +0000
libvisual-plugins (1:0.4.0+dfsg1-8) unstable; urgency=medium
* New maintainer. Thanks to all previous people that have helped this
......
......@@ -2,22 +2,24 @@ Source: libvisual-plugins
Section: sound
Priority: optional
Maintainer: Joao Eriberto Mota Filho <eriberto@debian.org>
Build-Depends: debhelper (>= 9),
Build-Depends: debhelper (>= 10),
autopoint,
bison,
dh-autoreconf,
libasound2-dev [linux-any],
libesd0-dev,
libgl1-mesa-dev,
libglu1-mesa-dev,
libgtk2.0-dev,
libjack-dev,
libvisual-0.4-dev (>= 0.4.0-4),
libx11-dev,
libxxf86vm-dev,
mesa-common-dev
Standards-Version: 3.9.6
Standards-Version: 3.9.8
Homepage: http://sf.net/projects/libvisual
Vcs-Browser: http://anonscm.debian.org/cgit/collab-maint/libvisual-plugins.git
Vcs-Git: git://anonscm.debian.org/collab-maint/libvisual-plugins.git
Vcs-Browser: https://anonscm.debian.org/git/collab-maint/libvisual-plugins.git
Vcs-Git: https://anonscm.debian.org/git/collab-maint/libvisual-plugins.git
Package: libvisual-0.4-plugins
Architecture: any
......
......@@ -59,7 +59,7 @@ Copyright: 2005-2006 David Schleef <ds@schleef.org>
2011 Ana Beatriz Guerrero Lopez <ana@debian.org>
2011-2012 Steve Langasek <vorlon@debian.org>
2012 Michael Biebl <biebl@debian.org>
2015 Joao Eriberto Mota Filho <eriberto@debian.org
2015-2016 Joao Eriberto Mota Filho <eriberto@debian.org
License: GPL-2+
License: GPL-2+
......
Description: fix a spelling error in final binary.
Author: Joao Eriberto Mota Filho <eriberto@debian.org>
Last-Update: 2016-10-09
Index: libvisual-plugins-0.4.0+dfsg1/plugins/actor/lv_gltest/actor_lv_gltest.c
===================================================================
--- libvisual-plugins-0.4.0+dfsg1.orig/plugins/actor/lv_gltest/actor_lv_gltest.c
+++ libvisual-plugins-0.4.0+dfsg1/plugins/actor/lv_gltest/actor_lv_gltest.c
@@ -115,7 +115,7 @@ int lv_gltest_init (VisPluginData *plugi
VisParamContainer *paramcontainer = visual_plugin_get_params (plugin);
static VisParamEntry params[] = {
- VISUAL_PARAM_LIST_ENTRY_INTEGER ("transparant bars", TRUE),
+ VISUAL_PARAM_LIST_ENTRY_INTEGER ("transparent bars", TRUE),
VISUAL_PARAM_LIST_END
};
@@ -133,8 +133,8 @@ int lv_gltest_init (VisPluginData *plugi
visual_param_container_add_many (paramcontainer, params);
- checkbox = visual_ui_checkbox_new (_("Transparant bars"), TRUE);
- visual_ui_mutator_set_param (VISUAL_UI_MUTATOR (checkbox), visual_param_container_get (paramcontainer, "transparant bars"));
+ checkbox = visual_ui_checkbox_new (_("Transperant bars"), TRUE);
+ visual_ui_mutator_set_param (VISUAL_UI_MUTATOR (checkbox), visual_param_container_get (paramcontainer, "transparent bars"));
visual_plugin_set_userinterface (plugin, checkbox);
@@ -240,7 +240,7 @@ int lv_gltest_events (VisPluginData *plu
case VISUAL_EVENT_PARAM:
param = ev.event.param.param;
- if (visual_param_entry_is (param, "transparant bars")) {
+ if (visual_param_entry_is (param, "transparent bars")) {
priv->transparant = visual_param_entry_get_integer (param);
if (priv->transparant == FALSE)
10_disable-gforce-dfsg
20_64-bit_JESS_fix
30_build_against_gl_fixes
40_lv_analyzer_build_fix
50_fix_po
60_alsa_m4_macro
70_no-const-vispluginfo-in-nastyfft
80_fix_FTBFS_clang
90_fix_some_gcc_warnings
10_disable-gforce-dfsg.patch
20_64-bit_JESS_fix.patch
30_build_against_gl_fixes.patch
40_lv_analyzer_build_fix.patch
50_fix_po.patch
60_alsa_m4_macro.patch
70_no-const-vispluginfo-in-nastyfft.patch
80_fix_FTBFS_clang.patch
90_fix_some_gcc_warnings.patch
95_fix_spelling.patch
......@@ -8,7 +8,7 @@ export DEB_CPPFLAGS_MAINT_APPEND := -D_GNU_SOURCE
dh $@ --with autoreconf
override_dh_auto_configure:
dh_auto_configure -- --disable-gdkpixbuf-plugin
dh_auto_configure -- --disable-gdkpixbuf-plugin --disable-gstreamer-plugin
override_dh_auto_install:
dh_auto_install
......
version=3
version=4
opts=dversionmangle=s/\+dfsg\d+$// \
http://sf.net/libvisual/libvisual-plugins-(\d\S+)\.tar\.(?:bz2|gz|xz)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment