Commit 5e31ec3d authored by Helmut Grohne's avatar Helmut Grohne Committed by Helmut Grohne

disable libunwind support by default

Given that libunwind is unavailable on a number of relevant
architectures (including s390x), we're going to disable the feature.
However it is left as an optional build feature to ease using it.

Acked-by: Stefan Bühler
parent e143c338
lighttpd (1.4.52-6) UNRELEASED; urgency=medium
* QA Upload.
* Disable libunwind support by default (unavailable on s390x).
Rebuild with DEB_BUILD_PROFILES=pkg.lighttpd.libunwind to use it.
-- Helmut Grohne <helmut.grohne@intenta.de> Sat, 26 Jan 2019 09:01:24 +0100
......
......@@ -31,7 +31,7 @@ Build-Depends:
libpam0g-dev,
libpq-dev,
libsasl2-dev,
libunwind8-dev,
libunwind8-dev <pkg.lighttpd.libunwind>,
perl:native,
Vcs-Git: https://salsa.debian.org/debian/lighttpd.git
Vcs-Browser: https://salsa.debian.org/debian/lighttpd
......
......@@ -35,7 +35,7 @@ override_dh_auto_configure:
--with-sasl \
--with-webdav-locks \
--with-webdav-props \
--with-libunwind \
$(if $(filter pkg.lighttpd.libunwind,$(DEB_BUILD_PROFILES)),--with-libunwind) \
CFLAGS_FOR_BUILD="$(shell dpkg-buildflags --get CFLAGS)" \
LDFLAGS_FOR_BUILD="$(shell dpkg-buildflags --get LDFLAGS)" \
CPPFLAGS_FOR_BUILD="$(shell dpkg-buildflags --get CPPFLAGS)" \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment