Commit 28b1992d authored by Jeremy Bicha's avatar Jeremy Bicha

Add python3-link-grammar package

parent 45e186ae
......@@ -2,6 +2,7 @@ link-grammar (5.3.13-1) UNRELEASED; urgency=medium
* QA upload
* New upstream release
* Add python3-link-grammar package
* Drop debian/patches/git_link-with-libstdcc.patch, applied in
new version
......
......@@ -13,6 +13,7 @@ Build-Depends:
minisat,
pkg-config,
python-dev,
python3-dev,
swig,
zlib1g-dev,
Standards-Version: 3.9.8
......@@ -153,6 +154,32 @@ Description: Carnegie Mellon University's link grammar parser (Python 2)
.
This package contains a Python 2 library for using link-grammar.
Package: python3-link-grammar
Architecture: any
Section: python
Depends:
liblink-grammar5,
${misc:Depends},
${python3:Depends},
${shlibs:Depends},
Recommends:
link-grammar-dictionaries-all,
Description: Carnegie Mellon University's link grammar parser (Python 3)
In Sleator, D. and Temperley, D. "Parsing English with a Link Grammar"
(1991), the authors defined a new formal grammatical system called a
"link grammar". A sequence of words is in the language of a link
grammar if there is a way to draw "links" between words in such a way
that the local requirements of each word are satisfied, the links do
not cross, and the words form a connected graph. The authors encoded
English grammar into such a system, and wrote this program to parse
English using this grammar.
.
link-grammar can be used for linguistic parsing for information
retrieval or extraction from natural language documents. It can also be
used as a grammar checker.
.
This package contains a Python 3 library for using link-grammar.
Package: link-grammar-dictionaries-en
Architecture: all
Multi-Arch: foreign
......
......@@ -4,7 +4,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-O1 -Wl,--as-needed
%:
dh $@ --with python2
dh $@ --with python2,python3
override_dh_auto_clean:
dh_auto_clean
......@@ -14,8 +14,7 @@ override_dh_auto_clean:
override_dh_auto_configure:
dh_auto_configure -- \
--disable-static \
--enable-pthreads \
--enable-python-bindings
--enable-pthreads
override_dh_autoreconf:
dh_autoreconf --as-needed
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment