Commit 356a104b authored by Jeremy Bicha's avatar Jeremy Bicha

Add python-link-grammar.examples

parent d6435789
......@@ -4,6 +4,9 @@ link-grammar (5.3.7-3) UNRELEASED; urgency=medium
* Have autopkgtest run upstream python tests too
* Add transitional packages for liblink-grammar4-dev
and liblink-grammar4-java
* Add python-link-grammar.examples
* Have python-link-grammar recommend link-grammar-dictionaries-all
since it's needed for the examples
-- Jeremy Bicha <jbicha@ubuntu.com> Tue, 28 Jun 2016 03:01:52 -0400
......
......@@ -6,8 +6,8 @@ Build-Depends:
ant [!hppa !m68k !sh4],
autoconf-archive,
debhelper (>= 9),
dh-autoreconf,
default-jdk [!hppa !m68k !sh4],
dh-autoreconf,
dh-python,
libedit-dev,
libhunspell-dev,
......@@ -69,9 +69,11 @@ Description: Carnegie Mellon University's link grammar parser (libraries)
.
This package contains the shared library.
# Can be dropped after Ubuntu 18.04
# Can be dropped after Ubuntu 18.04 LTS
Package: liblink-grammar4-dev
Depends: liblink-grammar-dev, ${misc:Depends}
Depends:
liblink-grammar-dev,
${misc:Depends},
Architecture: all
Priority: extra
Section: oldlibs
......@@ -105,9 +107,11 @@ Description: Carnegie Mellon University's link grammar parser (development heade
.
This package contains the header files and static libraries
# Can be dropped after Ubuntu 18.04
# Can be dropped after Ubuntu 18.04 LTS
Package: liblink-grammar4-java
Depends: liblink-grammar-java, ${misc:Depends}
Depends:
liblink-grammar-java,
${misc:Depends},
Architecture: all
Priority: extra
Section: oldlibs
......@@ -150,6 +154,8 @@ Depends:
${misc:Depends},
${python:Depends},
${shlibs:Depends},
Recommends:
link-grammar-dictionaries-all,
Description: Carnegie Mellon University's link grammar parser (Python 2)
In Sleator, D. and Temperley, D. "Parsing English with a Link Grammar"
(1991), the authors defined a new formal grammatical system called a
......
bindings/python-examples/*.py
bindings/python-examples/*.txt
......@@ -27,5 +27,8 @@ override_dh_install:
usr/lib/$(DEB_HOST_MULTIARCH)/jni
dh_install
override_dh_compress:
dh_compress --exclude=.py
override_dh_auto_test:
# We use autopkgtest instead
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment