...
 
Commits (8)
ostree (2018.8-2~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
- debian/gbp.conf: Adjust for this branch
-- Simon McVittie <smcv@debian.org> Thu, 04 Oct 2018 18:52:30 +0100
ostree (2018.8-2) unstable; urgency=medium
[ Simon McVittie ]
* ostree-tests: Remove gjs dependency on s390x.
mozjs60 doesn't work on s390x, so gjs is in danger of being removed
from that architecture (see #909536). The test that uses JS is
automatically skipped if the interpreter is missing.
(Closes: #910286)
* Standards-Version: 4.2.1 (no changes required)
[ Ondřej Nový ]
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
* d/changelog: Remove trailing whitespaces
-- Simon McVittie <smcv@debian.org> Thu, 04 Oct 2018 14:54:29 +0100
ostree (2018.8-1~bpo9+1) stretch-backports; urgency=medium
* Rebuild for stretch-backports.
......@@ -827,7 +850,7 @@ ostree (2015.9-alexlarsson1) vivid; urgency=medium
ostree (2015.4-0amigadave2) trusty; urgency=low
[ David King ]
* Add build dependency on libattr1-dev.
* Add build dependency on libattr1-dev.
-- David King <amigadave@amigadave.com> Wed, 08 Apr 2015 13:10:39 +0100
......
......@@ -46,7 +46,7 @@ Build-Depends:
Build-Depends-Indep:
libglib2.0-doc,
Rules-Requires-Root: no
Standards-Version: 4.2.0
Standards-Version: 4.2.1
Homepage: https://github.com/ostreedev/ostree/
Vcs-Git: https://salsa.debian.org/debian/ostree.git
Vcs-Browser: https://salsa.debian.org/debian/ostree
......@@ -156,7 +156,7 @@ Depends:
cpio,
fuse,
gir1.2-ostree-1.0,
gjs [!sparc64],
gjs [!s390x !sparc64],
gnupg,
ostree,
python3,
......
......@@ -6,8 +6,11 @@ ostree-tests: extra-license-file usr/libexec/installed-tests/libostree/gpg-verif
# This is deliberate, working around the assumption of recursive make
ostree-tests: symlink-is-self-recursive usr/libexec/installed-tests/libostree/tests .
# We won't run this on sparc64 currently
[sparc64]: missing-dep-for-interpreter gjs => gjs (usr/libexec/installed-tests/libostree/corrupt-repo-ref.js)
# gjs has been broken on sparc64 for a while, and is likely to be removed
# from s390x because mozjs60 doesn't work there.
# The test that runs this script is automatically skipped if gjs isn't
# present.
[s390x sparc64]: missing-dep-for-interpreter gjs => gjs (usr/libexec/installed-tests/libostree/corrupt-repo-ref.js)
# This shared object genuinely doesn't use any libc ABIs directly,
# only via GLib
......
......@@ -4,7 +4,7 @@ set -e
exec 2>&1
set -x
cd "$ADTTMP"
cd "$AUTOPKGTEST_TMP"
cat > trivial.c <<EOF
#include <ostree.h>
......