Commit 1cc22817 authored by Per Olofsson's avatar Per Olofsson

Simply debian/rules.

parent 412f1c11
......@@ -14,6 +14,7 @@ pcmciautils (018-1) UNRELEASED; urgency=low
* Bump Standards-Version to 3.9.2. No changes.
* Remove init script. Driver module should be loaded by udev or
/etc/modules. Add note to NEWS.Debian.
* Simply debian/rules.
-- Per Olofsson <pelle@debian.org> Mon, 25 Apr 2011 12:06:11 +0200
......
lib/udev lib/
usr/lib/pcmciautils/config.opts etc/pcmciautils/
#! /usr/bin/make -f
%:
dh $@
tmp := $(CURDIR)/debian/pcmciautils
tmp_udeb := $(CURDIR)/debian/pcmciautils-udeb
override_dh_auto_build:
$(MAKE) UDEV=true V=true
export V := true
override_dh_auto_clean:
$(MAKE) clean UDEV=true V=true
%:
dh $@
override_dh_auto_install:
$(MAKE) install UDEV=true DESTDIR=$(tmp) V=true \
pcmciaconfdir=\$${prefix}/usr/lib/pcmciautils
$(MAKE) install-tools install-udev install-config \
install-socket-tools UDEV=true DESTDIR=$(tmp_udeb) V=true
dh_auto_install --destdir=debian/pcmciautils -- \
pcmciaconfdir=/usr/lib/pcmciautils
override_dh_install:
dh_install --sourcedir=debian/pcmciautils
# You only need to run this immediately after checking out the package from
# revision control.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment