...
 
Commits (4)
python-irc (8.5.3+dfsg-5) UNRELEASED; urgency=medium
[ Ben Finney ]
* Use current HTTPS URL for copyright format declaration.
* Declare “Standards-Version: 4.2.1”. No additional changes needed.
* Declare Debhelper compatibility level 11.
......@@ -9,36 +10,13 @@ python-irc (8.5.3+dfsg-5) UNRELEASED; urgency=medium
* Update VCS URLs for Debian packaging.
* Describe current source package management in ‘README.source’.
--
[ Ondřej Nový ]
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
* d/changelog: Remove trailing whitespaces
* d/watch: Use https protocol
python-irc (8.5.3+dfsg-4) unstable; urgency=medium
* The “Faisal Arefin Dipan” release.
* Patch the unit tests to use a fake system clock.
Closes: bug#854539.
-- Ben Finney <bignose@debian.org> Sat, 18 Feb 2017 06:48:31 +1100
python-irc (8.5.3+dfsg-3) unstable; urgency=medium
* The “Mukto-Mona” release.
* Adopt this package. Thanks for your work, Daniel Baumann.
Closes: bug#730084.
* Set current VCS fields for Debian packaging.
* Configure UScan to monitor and fetch upstream source releases.
* Add configuration for Git-buildpackage.
* Remove Setuptools build artefacts during package clean.
* Document how the Debian package source is generated.
* Configure ‘mk-origtargz’ to omit unwanted files from upstream source.
* Declare “Standards-Version: 3.9.8”.
* Use more-precise “Expat” label for copyright license.
* Update copyright information.
* Remove override for package compression type; “xz” is now the default.
* Send HTTP traffic to the “discard” service during packaging actions.
* Migrate to Pybuild for packaging Python files.
* Build library packages for both Python 2 and Python 3.
-- Ben Finney <bignose@debian.org> Thu, 29 Dec 2016 08:41:09 +1100
--
python-irc (8.5.3+dfsg-2) unstable; urgency=low
......
......@@ -19,8 +19,6 @@ Standards-Version: 4.2.1
Homepage: https://pypi.org/project/irc/
VCS-git: https://salsa.debian.org/debian/pkg-python-irc.git
VCS-Browser: https://salsa.debian.org/debian/pkg-python-irc
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.2
Package: python3-irc
Architecture: all
......
......@@ -7,7 +7,7 @@ version = 4
# Current version from Python Package Index.
opts = "uversionmangle=s/(\d)((?:a|b|c|rc)\d*)$/$1~$2/,dversionmangle=s/\+dfsg$//" \
http://pypi.debian.net/irc/irc-(\S+)\.tar\.(?:gz|bz2|xz) \
https://pypi.debian.net/irc/irc-(\S+)\.tar\.(?:gz|bz2|xz) \
debian uupdate
......