...
 
Commits (2)
spamassassin (3.4.2-1~deb9u1) stable-security; urgency=medium
* Backport 3.4.2-1 to stretch.
* Revert changes for "Preserve locally set ENABLED=1 setting from
/etc/default/spamassassin when installing on systemd-based systems."
due to requirements on newer debhelper and init-system-helpers.
* Add libbsd-resource-perl to Suggests (Closes: 910434)
-- Noah Meyerhans <noahm@debian.org> Fri, 26 Oct 2018 08:12:52 -0700
spamassassin (3.4.2-1) unstable; urgency=medium
spamassassin (3.4.2-1~deb9u1) stretch; urgency=high
* New upstream release fixes multiple security vulnerabilities
- CVE-2017-15705: Denial of service issue in which certain unclosed
......@@ -29,8 +19,6 @@ spamassassin (3.4.2-1) unstable; urgency=medium
* Don't recursively chown /var/lib/spamassassin during postinst.
(Closes: 889501)
* Reload spamd after compiling rules in sa-compile.postinst.
* Preserve locally set ENABLED=1 setting from /etc/default/spamassassin
when installing on systemd-based systems. (Closes: 884163, 858457)
* Update SysV init script to cope with upstream's change to $0.
* Remove compiled rules upon removal of the sa-compile package.
* Ensure that /var/lib/spamassassin/compiled doesn't change modes with
......@@ -38,6 +26,7 @@ spamassassin (3.4.2-1) unstable; urgency=medium
* Update standards version to 4.2.1
* Create /var/lib/spamassassin via dpkg, rather than the postinst.
(Closes: 891833)
* Add libbsd-resource-perl to Suggests (Closes: 910434)
-- Noah Meyerhans <noahm@debian.org> Sun, 30 Sep 2018 23:44:58 -0700
......@@ -56,7 +45,7 @@ spamassassin (3.4.1-8) unstable; urgency=medium
* Remove references to the obsolete syslog.target dependency in the
systemd service file.
* Clarify the use of the perl-major-upgrade dpkg trigger.
* Fix spamd service manage on upgrades. (Closes: #865356)
* Fix spamd service management on package upgrades. (Closes: #865356)
-- Noah Meyerhans <noahm@debian.org> Sat, 09 Sep 2017 22:37:20 -0700
......