Commit f68cf0d4 authored by Aleks Kissinger's avatar Aleks Kissinger

added Info.plist (fixes #47)

parent d27a6bf5
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>CFBundleExecutable</key>
<string>tikzit</string>
<key>CFBundleIconFile</key>
<string>tikzit.icns</string>
<key>CFBundleIdentifier</key>
<string>io.github.tikzit</string>
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>LSMinimumSystemVersion</key>
<string>10.12</string>
<key>NSPrincipalClass</key>
<string>NSApplication</string>
<key>NSSupportsAutomaticGraphicsSwitching</key>
<true/>
<key>CFBundleVersion</key>
<string>@FULL_VERSION@</string>
<key>CFBundleShortVersionString</key>
<string>@FULL_VERSION@</string>
</dict>
</plist>
......@@ -37,6 +37,7 @@ PreviewWindow::PreviewWindow(QWidget *parent) :
_loader = new QLabel(ui->tabWidget->tabBar());
_loader->setMinimumSize(QSize(16,16));
_loader->setMaximumSize(QSize(16,16));
_loader->setAutoFillBackground(false);
ui->tabWidget->tabBar()->setTabButton(1, QTabBar::RightSide, _loader);
connect(ui->tabWidget, SIGNAL(currentChanged(int)),
......
......@@ -2,6 +2,8 @@
QT += core gui widgets network svg
VERSION = 2.1
test {
CONFIG += testcase
}
......@@ -25,6 +27,8 @@ win32:RC_ICONS += images/tikzdoc.ico
macx:ICON = images/tikzit.icns
# linux-g++:QMAKE_CXXFLAGS += -Wsuggest-override
QMAKE_INFO_PLIST = Info.plist
# Qt 5.8 and above drop support for Mountain Lion
contains(QT_VERSION, ^5\\.[5-7].*) {
macx:QMAKE_MACOSX_DEPLOYMENT_TARGET = 10.8
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment