Commit da432658 authored by Bernd Zeimetz's avatar Bernd Zeimetz

Restrict libmapnic-dev to arches where it is available.

parent 1329ddb7
......@@ -26,7 +26,7 @@ Build-Depends: debhelper (>= 7.2.14),
libmagic-dev,
gnome-common,
libsqlite3-dev,
libmapnik-dev
libmapnik-dev [!mips !mips64el !mipsel !hurd-i386 !kfreebsd-amd64 !kfreebsd-i386 !powerpcspe !sh4 !x32],
Standards-Version: 3.8.4
Homepage: http://viking.sf.net
Vcs-Git: git://git.debian.org/collab-maint/viking.git
......
......@@ -4,6 +4,7 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
EXTRAFLAGS := $(strip $(shell if ! dpkg -L libmapnik-dev 2>/dev/null | grep -q mapnik/map.hpp; then echo '--disable-mapnik'; fi))
%:
dh $@ --with autotools_dev,autoreconf
......@@ -16,6 +17,6 @@ override_dh_auto_clean:
override_dh_auto_configure:
intltoolize --force
dh_auto_configure -- $(shell dpkg-buildflags --export=configure)
dh_auto_configure -- $(shell dpkg-buildflags --export=configure) $(EXTRAFLAGS)
.PHONY: override_dh_auto_test
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment