...
 
Commits (2)
zbar (0.21-3) unstable; urgency=medium
* QA upload.
* debian/patches:
+ Replace custom codespell typo fix patches with upstream
applied one.
+ Cherry-pick upstream patches till 20190215 to fix grammar
error in configure.ac script.
* debian/control:
+ Mark libbarcode-zbar-perl, python-zbar and python-zbarpygtk
as Multi-Arch: same. (Closes: #812954)
* New zbarcam is no longer crashing. (Closes: #762209)
-- Boyuan Yang <byang@debian.org> Fri, 15 Feb 2019 10:35:13 -0500
zbar (0.21-2) unstable; urgency=medium
* QA upload.
......
......@@ -29,6 +29,7 @@ Vcs-Browser: https://salsa.debian.org/debian/zbar
Package: libbarcode-zbar-perl
Section: perl
Architecture: any
Multi-Arch: same
Depends:
${misc:Depends},
${perl:Depends},
......@@ -104,6 +105,7 @@ Description: bar code scanner and decoder (GTK+ bindings)
Package: python-zbar
Section: python
Architecture: any
Multi-Arch: same
Replaces:
python-zbarpygtk (<< 0.10+doc),
Breaks:
......@@ -123,6 +125,7 @@ Description: bar code scanner and decoder (Python bindings)
Package: python-zbarpygtk
Section: python
Architecture: any
Multi-Arch: same
Depends:
libzbar0 (= ${binary:Version}),
python-gtk2,
......
From: Mauro Carvalho Chehab <mchehab+samsung@kernel.org>
Date: Fri, 15 Feb 2019 04:56:11 -0200
Subject: configure.ac: fix an error at libv4l2 package check
Writing m4 logic is hard, as it is required to properly
mark begin/end of each block.
In the case of the libv4l detection check, there's a missing
[] for PKG_CHECK_MODULES(). This causes it to produce a wrong
code, ending by having 2 errors when the script runs:
checking for libv4l2.h... yes
./configure: line 15166: V4L2_CFLAGS: command not found
./configure: line 15167: V4L2_LIBS: command not found
While here, better ident the blocks and fix the error message
when libv4l2.so is not found.
Signed-off-by: Mauro Carvalho Chehab <mchehab+samsung@kernel.org>
---
configure.ac | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/configure.ac b/configure.ac
index da334e7..7e9cac6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,18 +241,19 @@ AS_IF([test "x$enable_video" = "xno"],
AC_CHECK_HEADERS([linux/videodev2.h], [have_v4l2="yes"])
AC_CHECK_HEADERS([libv4l2.h], [have_libv4l="yes"])
AS_IF([test "x$have_v4l2" = "xno" && test "x$have_v4l1" = "xno"],
- [AC_MSG_FAILURE([test for video support failed!
+ [AC_MSG_FAILURE([test for video support failed!
rebuild your kernel to include video4linux support or
configure --disable-video to skip building video support.])],
- [test "x$have_v4l2" = "xno"],
- [AC_MSG_WARN([v4l2 API not detected, upgrade your kernel!])])],
+ [AS_IF([test "x$have_v4l2" = "xno"],
+ [AC_MSG_WARN([v4l2 API not detected, upgrade your kernel!])])]
+ )],
[AC_CHECK_HEADERS([vfw.h], [with_video="vfw"],
[AC_MSG_FAILURE([test for VfW video support failed!
configure --disable-video to skip building video support.])])])
AS_IF([test "x$have_libv4l" = "xyes"],
- PKG_CHECK_MODULES([V4L2], [libv4l2], [],
- [AC_MSG_FAILURE([unable to find libv4l.so])]),
+ [PKG_CHECK_MODULES([V4L2], [libv4l2], [],
+ [AC_MSG_FAILURE([unable to find libv4l2.so])])],
[AC_MSG_WARN([libv4l not detected. Install it to support more cameras!])])
AM_CONDITIONAL([HAVE_VIDEO], [test "x$enable_video" != "xno"])
......@@ -55,7 +55,7 @@ index 5fd51ce..978e36f 100644
The zbarcam program uses the video4linux API (v4l1 or v4l2) to access
the video device. This interface is part of the linux kernel, a 3.16
diff --git a/configure.ac b/configure.ac
index da334e7..e9345c1 100644
index 7e9cac6..20d078b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,7 +14,7 @@ LT_INIT([dlopen win32-dll])
......@@ -67,7 +67,7 @@ index da334e7..e9345c1 100644
dnl LIB_VERSION update instructions copied from libtool docs:
dnl library version follows the form current:revision:age
dnl - If the library source code has changed at all since the last update,
@@ -404,7 +404,7 @@ AS_IF([test "x$with_imagemagick" = "xno"], [],
@@ -405,7 +405,7 @@ AS_IF([test "x$with_imagemagick" = "xno"], [],
[MAGICK_VERSION=`$PKG_CONFIG MagickWand --modversion`],
[dnl
dnl Wand is deprecated in favor of MagickWand,
......
0001-debian-zbar-zbarimg-exit-gracefully-when-decoding-sp.patch
0002-zbar-fix-some-typos.patch
0003-Fix-typos-found-by-codespell.patch
0003-configure.ac-fix-an-error-at-libv4l2-package-check.patch
0004-Fix-typos-found-by-codespell.patch