Commit 84009639 authored by Nicholas Breen's avatar Nicholas Breen

Add hppa, s390x, x32 to list of architectures for gromacs-openmpi.

parent ee7ce3a2
gromacs (5.1.2-1) unstable; urgency=medium
* New upstream release.
* Add hppa, s390x, x32 to list of architectures for gromacs-openmpi.
In turn, increase required version of libopenmpi-dev to >= 1.10.2-7.
* Add new patches/reproducible-builds.patch for... reproducible builds.
This is preliminary work and may not be complete.
* Update Standards-Version to 3.9.7, no changes required.
-- Nicholas Breen <nbreen@debian.org> Fri, 19 Feb 2016 16:30:09 -0800
......
......@@ -10,7 +10,7 @@ Build-Depends: cmake,
libfftw3-dev,
liblapack-dev,
libmpich-dev (>= 3.0.4-6),
libopenmpi-dev (>= 1.2.4-5) [alpha amd64 arm64 armel armhf hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el sparc sparc64],
libopenmpi-dev (>= 1.10.2-7) [alpha amd64 arm64 armel armhf hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32],
libx11-dev,
libxml2-dev,
zlib1g-dev
......@@ -23,7 +23,7 @@ Build-Depends-Indep: doxygen,
texlive-fonts-recommended,
texlive-latex-base,
texlive-latex-extra
Standards-Version: 3.9.6
Standards-Version: 3.9.7
Homepage: http://www.gromacs.org/
Vcs-Browser: http://anonscm.debian.org/viewvc/debichem/
Vcs-Svn: svn://anonscm.debian.org/debichem/unstable/gromacs/
......@@ -92,7 +92,7 @@ Depends: fftw3-dev,
${misc:Depends},
${shlibs:Depends}
Recommends: gromacs-data
Suggests: gromacs-mpich (= ${binary:Version}) | gromacs-openmpi (= ${binary:Version}) [alpha amd64 arm64 armel armhf hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el sparc sparc64],
Suggests: gromacs-mpich (= ${binary:Version}) | gromacs-openmpi (= ${binary:Version}) [alpha amd64 arm64 armel armhf hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32],
libmpich-dev,
libx11-dev,
zlib1g-dev
......@@ -144,7 +144,7 @@ Description: Molecular dynamics sim, binaries for MPICH parallelization
processing cluster, or for multiprocessor machines.
Package: gromacs-openmpi
Architecture: alpha amd64 arm64 armel armhf hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el sparc sparc64
Architecture: alpha amd64 arm64 armel armhf hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
Depends: openmpi-bin (>= 1.2.3), ${misc:Depends}, ${shlibs:Depends}
Recommends: gromacs
Suggests: gromacs-data
......
......@@ -10,7 +10,7 @@ PACKAGE := gromacs
# This list should remain synced with the Build-Depends and the Architecture
# line of gromacs-openmpi in debian/control.
OPENMPI_ARCH = alpha amd64 armel armhf arm64 i386 ia64 powerpc powerpcspe ppc64 ppc64el sparc sparc64 kfreebsd-i386 kfreebsd-amd64 hurd-i386 mips64 mips64el mips mipsel
OPENMPI_ARCH = alpha amd64 arm64 armel armhf hppa hurd-i386 i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mips64 mips64el mipsel powerpc powerpcspe ppc64 ppc64el s390x sparc sparc64 x32
DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment