Commit 4b317a57 authored by Piotr Roszatycki's avatar Piotr Roszatycki

Apply patch from upstream's master: fixes "-h" option for fakechroot script

parent b4be547e
fakechroot (2.17.1-2) unstable; urgency=medium
* Apply patch from upstream's master: fixes "-h" option for fakechroot
script.
-- Piotr Roszatycki <dexter@debian.org> Mon, 16 Dec 2013 20:17:52 +0100
fakechroot (2.17.1-1) unstable; urgency=low
* New upstream release:
......
From 0290fd97a964214289303a8b9d7e184ef9fc818b Mon Sep 17 00:00:00 2001
From: Juan RP <xtraeme@gmail.com>
Date: Sat, 14 Dec 2013 07:00:00 +0100
Subject: [PATCH 2/5] scripts/fakechroot.sh: fix -h and others (die ->
fakechroot_die).
---
scripts/fakechroot.sh | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/fakechroot.sh b/scripts/fakechroot.sh
index 1f11720..7738153 100644
--- a/scripts/fakechroot.sh
+++ b/scripts/fakechroot.sh
@@ -17,7 +17,7 @@ fakechroot_die () {
fakechroot_usage () {
- die "Usage:
+ fakechroot_die "Usage:
fakechroot [-l|--lib fakechrootlib] [-d|--elfloader ldso]
[-s|--use-system-libs]
[-e|--environment type] [-c|--config-dir directory]
@@ -60,7 +60,7 @@ fakechroot_next_cmd () {
if [ "$FAKECHROOT" = "true" ]; then
- die "fakechroot: nested operation is not supported"
+ fakechroot_die "fakechroot: nested operation is not supported"
fi
--
1.8.3.2
# series file
scripts-fakechroot.sh-fix-h-and-others-die-fakechroo.patch
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment