Commit 66d7fb69 authored by Josselin Mouette's avatar Josselin Mouette

* New upstream stable release, with ABI and API changes wrt poppler 0.8.

  - Rename libpoppler3 to libpoppler4, libpoppler-glib3 to libpoppler-glib4;
    libpoppler-qt2 and libpoppler-qt4-3 are not renamed; update control,
    DEB_DH_MAKESHLIBS_ARGS_* in rules, and rename install files.
  - Add shlib version for libpoppler-qt4-3.
  - Drop patches 60_manpages-cfg-flag.patch, 61_manpages-hyphens.patch, and
    62_pdftops-mandatory-arg.patch, merged upstream.
* Build-dep on libopenjpeg-dev for better JPEG2000 reading.
* Build-depend explicitly on libjpeg-dev, libfreetype6-dev and 
  libxml2-dev.
* Bump requirement on libqt4-dev.

svn path=/trunk/poppler/; revision=223
parent 4e2c4d72
poppler (0.10.4-1) unstable; urgency=low
[ Pino Toscano ]
* New upstream stable release, with ABI and API changes wrt poppler 0.8.
- Rename libpoppler3 to libpoppler4, libpoppler-glib3 to libpoppler-glib4;
libpoppler-qt2 and libpoppler-qt4-3 are not renamed; update control,
DEB_DH_MAKESHLIBS_ARGS_* in rules, and rename install files.
- Add shlib version for libpoppler-qt4-3.
- Drop patches 60_manpages-cfg-flag.patch, 61_manpages-hyphens.patch, and
62_pdftops-mandatory-arg.patch, merged upstream.
* Build-dep on libopenjpeg-dev for better JPEG2000 reading.
[ Josselin Mouette ]
* Build-depend explicitly on libjpeg-dev, libfreetype6-dev and
libxml2-dev.
* Bump requirement on libqt4-dev.
-- Josselin Mouette <joss@debian.org> Fri, 06 Mar 2009 12:54:09 +0100
poppler (0.8.7-1) unstable; urgency=low
* Bump up Standards-Version to 3.8.0.
......
......@@ -13,14 +13,18 @@ Build-Depends: cdbs (>= 0.4.52),
libgtk2.0-dev (>= 2.4.0),
libfontconfig1-dev,
libqt3-mt-dev (>= 3:3.3.4-4),
libqt4-dev,
libqt4-dev (>= 4.1.0),
libglade2-dev,
libcairo2-dev (>= 1.4),
libopenjpeg-dev,
libjpeg-dev,
libfreetype6-dev,
libxml2-dev,
gtk-doc-tools (>= 1.0),
pkg-config (>= 0.18)
Standards-Version: 3.8.0
Package: libpoppler3
Package: libpoppler4
Architecture: any
Section: libs
Depends: ${shlibs:Depends},
......@@ -33,7 +37,7 @@ Description: PDF rendering library
Package: libpoppler-dev
Architecture: any
Section: libdevel
Depends: libpoppler3 (= ${binary:Version}),
Depends: libpoppler4 (= ${binary:Version}),
libfontconfig1-dev,
${shlibs:Depends},
${misc:Depends}
......@@ -43,7 +47,7 @@ Description: PDF rendering library -- development files
This package contains the headers and development libraries needed to
build applications using Poppler.
Package: libpoppler-glib3
Package: libpoppler-glib4
Architecture: any
Section: libs
Depends: ${shlibs:Depends},
......@@ -57,7 +61,7 @@ Description: PDF rendering library (GLib-based shared library)
Package: libpoppler-glib-dev
Architecture: any
Section: libdevel
Depends: libpoppler-glib3 (= ${binary:Version}),
Depends: libpoppler-glib4 (= ${binary:Version}),
libpoppler-dev (= ${binary:Version}),
libglib2.0-dev (>= 2.6),
libpango1.0-dev,
......@@ -141,7 +145,7 @@ Architecture: any
Section: libs
Priority: extra
Depends: ${misc:Depends},
libpoppler3 (= ${binary:Version}),
libpoppler4 (= ${binary:Version}),
${shlibs:Depends}
Description: PDF rendering library - detached debugging symbols
Poppler is a PDF rendering library based on xpdf PDF viewer.
......
Debian #461961; FreeDesktop #17222; drop unimplemented -cfg flag from man
pages.
--- poppler-0.8.6/utils/pdffonts.1 2008-03-26 20:38:52.000000000 +0100
+++ poppler-0.8.6.new/utils/pdffonts.1 2008-08-20 13:27:50.000000000 +0200
@@ -82,11 +82,6 @@
.BI \-upw " password"
Specify the user password for the PDF file.
.TP
-.BI \-cfg " config-file"
-Read
-.I config-file
-in place of ~/.xpdfrc or the system-wide config file.
-.TP
.B \-v
Print copyright and version information.
.TP
--- poppler-0.8.6/utils/pdfinfo.1 2008-03-26 20:38:52.000000000 +0100
+++ poppler-0.8.6.new/utils/pdfinfo.1 2008-08-20 13:27:58.000000000 +0200
@@ -111,11 +111,6 @@
.BI \-upw " password"
Specify the user password for the PDF file.
.TP
-.BI \-cfg " config-file"
-Read
-.I config-file
-in place of ~/.xpdfrc or the system-wide config file.
-.TP
.B \-v
Print copyright and version information.
.TP
--- poppler-0.8.6/utils/pdftops.1 2008-03-26 20:38:52.000000000 +0100
+++ poppler-0.8.6.new/utils/pdftops.1 2008-08-20 13:28:07.000000000 +0200
@@ -178,11 +178,6 @@
Don't print any messages or errors.
.RB "[config file: " errQuiet ]
.TP
-.BI \-cfg " config-file"
-Read
-.I config-file
-in place of ~/.xpdfrc or the system-wide config file.
-.TP
.B \-v
Print copyright and version information.
.TP
--- poppler-0.8.6/utils/pdftotext.1 2008-03-26 20:38:52.000000000 +0100
+++ poppler-0.8.6.new/utils/pdftotext.1 2008-08-20 13:28:12.000000000 +0200
@@ -85,11 +85,6 @@
Don't print any messages or errors.
.RB "[config file: " errQuiet ]
.TP
-.BI \-cfg " config-file"
-Read
-.I config-file
-in place of ~/.xpdfrc or the system-wide config file.
-.TP
.B \-v
Print copyright and version information.
.TP
FreeDesktop #17225; fixes escaping of hyphens in man pages
--- poppler-0.8.6/utils/pdfinfo.1 2008-08-20 17:37:28.000000000 +0200
+++ poppler-0.8.6.new/utils/pdfinfo.1 2008-08-20 17:37:58.000000000 +0200
@@ -81,7 +81,7 @@
.TP
.BI \-f " number"
Specifies the first page to examine. If multiple pages are requested
-using the "-f" and "-l" options, the size of each requested page (and,
+using the "\-f" and "\-l" options, the size of each requested page (and,
optionally, the bounding boxes for each requested page) are printed.
Otherwise, only page one is examined.
.TP
--- poppler-0.8.6/utils/pdftops.1 2008-08-20 17:37:28.000000000 +0200
+++ poppler-0.8.6.new/utils/pdftops.1 2008-08-20 17:39:43.000000000 +0200
@@ -25,7 +25,7 @@
.I file.ps
(or
.I file.eps
-with the -eps option). If
+with the \-eps option). If
.I PS-file
is \'-', the PostScript is sent to stdout.
.SH CONFIGURATION FILE
@@ -49,8 +49,8 @@
Generate Level 1 PostScript. The resulting PostScript files will be
significantly larger (if they contain images), but will print on Level
1 printers. This also converts all images to black and white. No
-more than one of the PostScript level options (-level1, -level1sep,
--level2, -level2sep, -level3, -level3Sep) may be given.
+more than one of the PostScript level options (\-level1, \-level1sep,
+\-level2, \-level2sep, \-level3, \-level3Sep) may be given.
.RB "[config file: " psLevel ]
.TP
.B \-level1sep
@@ -77,20 +77,20 @@
.TP
.B \-level3Sep
Generate Level 3 separable PostScript. The separation handling is the
-same as for -level2Sep.
+same as for \-level2Sep.
.RB "[config file: " psLevel ]
.TP
.B \-eps
Generate an Encapsulated PostScript (EPS) file. An EPS file contains
a single image, so if you use this option with a multi-page PDF file,
-you must use -f and -l to specify a single page. No more than one of
-the mode options (-eps, -form) may be given.
+you must use \-f and \-l to specify a single page. No more than one of
+the mode options (\-eps, \-form) may be given.
.TP
.B \-form
Generate a PostScript form which can be imported by software that
understands forms. A form contains a single page, so if you use this
-option with a multi-page PDF file, you must use -f and -l to specify a
-single page. The -level1 option cannot be used with -form.
+option with a multi-page PDF file, you must use \-f and \-l to specify a
+single page. The \-level1 option cannot be used with \-form.
.TP
.B \-opi
Generate OPI comments for all images and forms which have OPI
FreeDesktop #17226; Debian #491816; fixes synopsis of pdftops in man page to
clarify that a PDF file is required in all cases
--- poppler-0.8.6/utils/pdftops.1 2008-08-20 17:40:48.000000000 +0200
+++ poppler-0.8.6.new/utils/pdftops.1 2008-08-20 17:41:22.000000000 +0200
@@ -6,8 +6,8 @@
.SH SYNOPSIS
.B pdftops
[options]
-.RI [ PDF-file
-.RI [ PS-file ]]
+.RI <PDF-file>
+.RI [<PS-file>]
.SH DESCRIPTION
.B Pdftops
converts Portable Document Format (PDF) files to PostScript so they
......@@ -23,8 +23,8 @@ DEB_CONFIGURE_EXTRA_FLAGS += \
--enable-gtk-doc \
--disable-gtk-test
DEB_DH_MAKESHLIBS_ARGS_libpoppler3 += -V"libpoppler3"
DEB_DH_MAKESHLIBS_ARGS_libpoppler-glib3 += -V"libpoppler-glib3"
DEB_DH_MAKESHLIBS_ARGS_libpoppler4 += -V"libpoppler4"
DEB_DH_MAKESHLIBS_ARGS_libpoppler-glib4 += -V"libpoppler-glib4"
DEB_DH_MAKESHLIBS_ARGS_libpoppler-qt2 += -V"libpoppler-qt2 (>= 0.6)"
DEB_DH_MAKESHLIBS_ARGS_libpoppler-qt4-3 += -V"libpoppler-qt4-3"
DEB_DH_MAKESHLIBS_ARGS_libpoppler-qt4-3 += -V"libpoppler-qt4-3 (>= 0.10)"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment