Commit b0cce08b authored by Pino Toscano's avatar Pino Toscano

07_CVE-2010-4653.patch: include Object.h

really needed for likely/unlikely
parent c1a92b89
......@@ -3,8 +3,8 @@ poppler (0.12.4-1.2+squeeze1) UNRELEASED; urgency=low
* Add myself as uploader.
* Fix CVE-2010-0206.
* Fix CVE-2010-0207; patch adapted to be API-/ABI-compatible.
* Fix CVE-2010-4653; patch adapted to not include goo/GooLikely.h
(non-existent in poppler 0.12.x).
* Fix CVE-2010-4653; patch adapted to include object.h instead
of goo/GooLikely.h (non-existent in poppler 0.12.x).
-- Pino Toscano <pino@debian.org> Wed, 27 Jun 2012 18:36:18 +0200
......
......@@ -22,6 +22,14 @@ index 1835ddd..3cfa402 100644
// Copyright (C) 2007 Julien Rebetez <julienr@svn.gnome.org>
// Copyright (C) 2007 Koji Otani <sho@bbr.jp>
// Copyright (C) 2008 Michael Vrable <mvrable@cs.ucsd.edu>
@@ -36,6 +36,7 @@
#include <string.h>
#include "goo/gmem.h"
#include "goo/gfile.h"
+#include "Object.h"
#include "goo/GooString.h"
#include "Error.h"
#include "GlobalParams.h"
@@ -366,10 +367,15 @@ void CharCodeToUnicode::addMapping(CharCode code, char *uStr, int n,
if (code >= mapLen) {
oldLen = mapLen;
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment