debian-changes 1.52 KB
Newer Older
1 2 3 4 5 6 7 8 9 10
Subject: Collected Debian patches for dnsviz
Author: Debian DNS Maintainers <pkg-dns-devel@lists.alioth.debian.org>

The dnsviz package is maintained in Git rather than maintaining
patches as separate files, and separating the patches doesn't seem to
be worth the effort.  They are therefore all included in this single
Debian patch.

For full commit history and separated commits, see the packaging Git
repository.
11 12 13 14 15
--- dnsviz-0.6.6.orig/setup.py
+++ dnsviz-0.6.6/setup.py
@@ -20,10 +20,21 @@ else:
     from setuptools.command.install import install
     from setuptools.command.build_py import build_py
16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38
 
-JQUERY_UI_PATH = "'http://code.jquery.com/ui/1.11.4/jquery-ui.min.js'"
-JQUERY_UI_CSS_PATH = "'http://code.jquery.com/ui/1.11.4/themes/redmond/jquery-ui.css'"
-JQUERY_PATH = "'http://code.jquery.com/jquery-1.11.3.min.js'"
-RAPHAEL_PATH = "'http://cdnjs.cloudflare.com/ajax/libs/raphael/2.1.4/raphael-min.js'"
+# Requires libjs-jquery-ui
+JQUERY_UI_PATH = \
+    "'file:///usr/share/javascript/jquery-ui/jquery-ui.min.js'"
+
+# Requires libjs-jquery-ui-theme-redmond
+JQUERY_UI_CSS_PATH = \
+    "'file:///usr/share/javascript/jquery-ui-themes/redmond/jquery-ui.css'"
+
+# Requires libjs-jquery
+JQUERY_PATH = \
+    "'file:///usr/share/javascript/jquery/jquery.min.js'"
+
+# Requires libjs-raphael
+RAPHAEL_PATH = \
+    "'file:///usr/share/javascript/raphael/raphael.min.js'"
 
 def apply_substitutions(filename, install_prefix):
     assert filename.endswith('.in'), 'Filename supplied for customization must end with \'.in\': %s' % (filename)