Revert cve patches to their original version, add debian patch to skip privileged tests

The cve-2018-15664-* patches come from upstream, but the tests units
were removed, as they require root.

I find it a bit misleading to have modified version of upstream patches,
especially if there's no message in the patch header indicating that the
patches were modified.

This commit brings the patches back to their original form, identical
to upstream, and introduce a third patch to disable the tests if user is
not root.

Signed-off-by: Arnaud Rebillout <arnaud.rebillout@collabora.com>
8 jobs for master in 136 minutes and 55 seconds (queued for 189 minutes and 26 seconds)
Status Job ID Name Coverage
  Check
passed #204849
cme allowed to fail
dpkg-control

00:01:22

passed #204848
cme
dpkg-copyright

00:00:06

passed #204847
yamllint
yamllint

00:00:35

 
  Build
passed #204854
amd64 pbuilder
experimental-amd64

01:00:30

passed #204851
amd64 pbuilder
testing_unstable-amd64

01:05:06

passed #204853
amd64 pbuilder
unstable-amd64

01:02:18

passed #204850
amd64 pbuilder
unstable-binary-indep

00:09:36

passed #204852
amd64 pbuilder
unstable-i386

01:04:43